Lesson 1
Setting up Maya

Setting up Maya
Before beginning, install Maya and add the Learning Maya support files to your projects directory. These can be found on the support_files directory on the DVD-ROM included with this book.

Note: To avoid the Can't save Workspace error, ensure that the support files are not read-only after you copy them from the DVD-ROM.

If you have been working with Maya and have changed any of your user interface settings, you may want to delete your preference files in order to start with the default Maya configuration.

If you are running multiple versions of Maya on the same machine, you should also backup and delete the preference files for those versions. Otherwise, Maya will use those preferences when it first launches and some of the new marking menu and hotkey settings will not be available. You can replace them later when you know that your Maya prefs have been created.

Creating a new project
Maya uses the concept of a project to organize files. You can create project directories that contain sub-directories for storing your files.

1. Launch Maya
   - To get started, you need to launch Maya.

2. Set the courseware project
   - To manage your files, you can set a project directory that contains sub-directories for different types of files that relate to your project.

   - Go to the File menu and select Project ➔ Set...
     A window opens that points you to the Maya projects directory.
   - Open the folder named support_files.
   - Click on the folder named projectourselect it.
   - Click on the OK button.

   This sets the learningMaya directory as your current project.

   - Go to the File menu and select Project ➔ Edit Current...
     Make sure that the project directories are set up as shown below. This ensures that Maya is looking into the proper subdirectories when it opens up scene files.

3. Make a new scene
   - Select File ➔ New Scene,
     This makes sure that your current scene is part of the new project.

Building objects
Every scene you create in Maya will begin with objects. These objects can include things like surfaces, deformers, skeletons, joints or particle emitters. For this scene, you will build a ball and a floor surface.

Creating the ball
To start, you will build a few simple objects that you will animate, texture and render. The first object is a primitive sphere which will act as the ball.

1. Change menu sets
   - There are four main menu sets in Maya: Animation, Modeling, Dynamics and Rendering. These menu sets are used to access related tool sets.
     - From the pop-up menu at the left edge of the Status line, select Modeling.
     - As you change menu sets, the first six menus remain the same while the remaining menus change to reflect the chosen menu set.

2. Create a NURBS sphere
   - A primitive sphere will be used for the ball. It will be built using non-uniform rational b-spline (NURBS) geometry. In later lessons, you will learn more about this geometry type.
     - From the Create menu, select NURBS Primitives ➔ Sphere.
     A sphere is placed at the origin.

3. Change the ball's radius
   - The sphere is a procedural model. This means that it is broken down into parts called nodes. One node contains its positioning information, one contains its shape information and another contains input information that defines the sphere's construction history using attributes such as radius, sweep, and degree. You can edit...
Moving the ball

You will now use the Move tool to reposition the ball. This will involve the use of manipulator handles that let you control where you move your object.

1. Position the ball
   You can now use the Move tool to reposition the sphere above the working grid.

   - Select the Move tool.
   - Click-drag on the green manipulator handle to move the sphere along the Y-axis.
   - The manipulator handle turns yellow to indicate that it is active.

2. Create four view panels
   By default, a single perspective window is shown in the workspace. To see other views of the scene, you can change your panel layout.

   - At the top of the Perspective view panel, go to the Panels menu and select Saved Layouts → Four View.

   You can now see the sphere using three orthographic views – Top, Side, and Front – which show you the model from a projected view. You can also see it in a Perspective view that is more like the 3D world we see every day. This multiple view setup is very useful when positioning objects in 3D space.

3. Reposition the ball
   When moving in an orthographic view, you can work in two axes at once by dragging on the center of the manipulator or constraining the motion along a single axis using the handles.

   - In the Front view, click-drag on the square center of the manipulator to move the sphere along both the X and the Y axes.

   - Use the manipulator in the various view windows to position the sphere on top of the ground plane as shown below.
Create a floor surface

To create a floor surface, a primitive plane is used. This plane using polygonal geometry which is different from the sphere which uses NURBS geometry. You can use the hotbox as an alternative method for accessing tools.

1 Create a polygonal plane
   - In a view panel, press and hold the spacebar to display the hotbox
   - In the hotbox, select Create → Polygon Primitives → Plane.
   A plane is placed at the origin of the scene.

2 Change construction history
   Just like the sphere, you can edit the plane using its input node. You will increase the size of the plane, then reduce the number of subdivisions to simplify the plane. Since the floor will not be deformed, the extra polygons are not required.
   - In the Channel box shown at the right side of your screen, click on the `polyPlane` Input node.
   - Set the following:
     * Width to 40;
     * Height to 40;
     * Subdivisions Width to 1;
     * Subdivisions Height to 1

Tip:
You can access all functions in Maya using either the main menus or the hotbox. As you become more familiar with the hotbox, you can use the interface options found in the Display menu to turn off the panel menu and therefore reduce screen clutter.

Note:
If you click-drag on the center of the manipulator in the Perspective view, you will notice that it doesn’t move along any particular axis. It is actually moving along the camera’s view plane.

3 Rename the plane node
   It is a good idea to rename the existing transform node to make it easier to find later.
   - Click on the polyPlane name in the top of the channel box.
   - Enter the name `floor`.

Create a Ring

You are now going to add a NURBS torus to the scene that will act as a hoop for the ball to jump through when you animate it bouncing.

1 Create a NURBS Torus
   The torus offers a shape that is perfect for the ring. You will create the torus, and then size and position it to get the ring.
   - From the Create menu, select NURBS Primitives → Torus
   - In the Channel box, click on the `makeNurbsTorus` Input node.
   - Set the following attributes:
     * Radius to 5;
     * Sections to 16;
     * Height Ratio to 0.05

2 Position the Torus
   - In the `nurbsTorus` section of the Channel box, set the following attribute:
     * Rotate Z to 90
   - Rename this node to `ring`
   - With your middle mouse button click in the perspective view to make it active then press the `w` key to select the Move tool.
   - Move the ring up so that it sits above the ground plane. Its Translate Y attribute should read about 12.
**Viewing the scene**

When you work in 3D space, it is important to see your work from different angles. The different view panels let you see your work from the Front, Top, Side and Perspective.

You can also use Maya’s view tools to change the views to reposition how you see your scene. In some cases, a view change is like panning a camera around a room, while in other cases a view change might be like turning an object around in your hand to see all the sides. These view tools can be accessed using the Alt key in combination with various mouse buttons.

1. **Edit the Perspective view**

You can use the Alt key with either your left mouse button (LMB), your middle mouse button (MMB) or the two together to tumble, track and dolly in your Perspective view.

- Change your view using the following key combinations:
  - Alt + LMB to tumble;
  - Alt + MMB to track;
  - Alt + LMB & MMB to dolly

You can also use the Ctrl key to create a bounding box dolly, where the view adjusts based on a bounding box:

- Ctrl + Alt + LMB to box dolly.
- Click-drag to the right to dolly in and to the left to dolly out.

You can also undo and redo view changes using the following keys:

- [ to undo views; and
- ] to redo views

2. **Edit the view in the Side view**

Orthographic views use similar hot keys except that you cannot tumble an orthographic view.

- In the Side view, change your view using the following key combinations:
  - Alt + MMB to track;
  - Alt + LMB & MMB to dolly

Keep working with the orthographic views until they are set up as shown in the following.

**Setting display options**

The view panels let you interactively view your scene. By default, this means viewing your scene as a wireframe model. To better evaluate the form of your objects, you can activate hardware shading and increase the sphere’s smoothness.

1. **Turn on Hardware shading**

To help visualize your objects, you can use hardware rendering to display a shaded view within any panel.

- From the Perspective view’s Shading menu, select Smooth Shade All.

This setting affects all of the objects within the current view panel.

2. **Hide the grid**

You can hide the grid to simplify your view using one of two options:

- From the Perspective panel’s Show menu, select Grid to hide the grid for that view only

OR

- From the Display menu, deselect Grid to hide the grid for all views.

3. **Adjust the sphere’s smoothness**

To better evaluate the sphere’s surface qualities, you can increase the smoothness:

- Select the ball.
- From the main Display menu, select NURBS Smoothness → Fine.
Lesson 1
Setting keys

This setting affects how selected
NURBS objects are displayed in all
view panels.

4 Adjust the ring’s smoothness
Maya also includes some hotkeys for
setting surface smoothness:
- Select the ring
- Press the 3 key
The smoothness setting allows you
to see your objects at various
degrees of complexity without
actually altering the geometry.

Next, you will add in the peaks and valleys of the
bouncing

Setting keys
To animate the ball, you must define its
position at certain points in time. This is
accomplished by setting keys. As you
playback the animation, Maya reads these key
positions and interpolates the position of the
ball in between the keyframes.

1 Position the ball
- Select the ball
- Move the ball along the X axis to the
edge of the floor. Use the Red
manipulator handle to constrain
along X

2 Set a start key on the ball
You will use the current position to set a
key for frame 1
- Select the ball
- Make sure that the current time is
set to 1 in the Time slider
- Press F2 to select the animation
menu set

- From the Animate menu, select Set
Key.
This places a key at frame 1 for all
of the ball’s translation attributes

Tip:
The menu sets can be changed using the
following hotkeys:
F2 - Animation
F3 - Modeling
F4 - Dynamics
F5 - Rendering

3 Set end key on the ball
A new position for the ball can be set for
frame 60
- In the Time slider, change the end
time and the playback end time to
60 and press Enter

Repositioning the ball

ANIMATING THE BALL
You now have your scene set up and ready to
animate. Using the ball node, you will start by
keying the overall translation of the ball.

- Tip:
A NURBS object can have its
smoothness set using the following
hotkeys:
1 - rough
2 - medium
3 - fine

- Note:
Playback will only be visible in the view
panel that is highlighted. If you are not
seeing any playback then be sure to
click in the perspective panel with your
middle mouse button.

Sphere moved along X-axis
- Press the 8 key to Set Key at this
position and time

- Tip:
The 8 key is a hotkey for the Set key
command

- Playback the results using the
Playback controls which are located
in the lower right corner

Tip:
The 8 key is a hotkey for the Set key
command

- Playback the results using the
Playback controls which are located
in the lower right corner

Note:
Playback will only be visible in the view
panel that is highlighted. If you are not
seeing any playback then be sure to
click in the perspective panel with your
middle mouse button.
4 Add intermediate keys
To make the ball hit the ground four times, you will need two more key positions set at frames 20 and 40.

Any time you want to make sure an object is at a certain place at a certain time, set a key:
- Drag the Time slider to frame 20
- The ball is positioned based on existing keys
- Press the s key to Set Key
- Drag the Time slider to frame 40
- Press the s key to Set Key

You now have keys set at the following frames:

1  20  40  60

Diagram of initial keys

Tip: Every time you set a key, a red mark is placed on the Time slider to help you identify which your keys are.

5 Add more intermediate keys
To create the peaks of the bounce, you need to set new keys at frames 10, 30 and 50. These keys will require that you move the ball into a new position along the Y-axis:
- Move the Time slider to frame 30
- Click-drag on the green Y-axis manipulator to move the sphere up along the Y-axis until it sits inside the ring
- Press the s key to Set Key

6 Set the playback speed
- Click the Animation Preferences button found at the far right side of the Range slider.

This opens a window that lets you set various animation and playback options. Currently, the scene is playing back as fast as it can. Since you only have two objects, playback is a little too fast.

In the Playback section, set the following:
- Playback Speed to Real-time.
- Click the Save button
- Playback the results using the Time slider controls

7 Save your work
- From the File menu, select Save Scene As...
- Enter the name bounce_01.

Window Save As dialog box
- Click the Save button or press the Enter key

Make sure you save this file since you will be continuing with it in the next lesson.
Adding Character

In the last lesson, you built and animated a bouncing ball. As you playback the bounce, you can see that the ball seems to float and is not bouncing in a convincing manner. In this lesson, you will begin to edit the quality of the original animation to add character to the bounce.

This lesson will begin to layer the animation with secondary motion such as squash and stretch. In Maya, you can create these effects using non-linear deformers, that allow you to reshape the ball as it animates.

Adding squash and stretch

In this lesson you will learn the following:

- How to refine animated channels with the Graph Editor
- How to create a Bend and a Squash deformer
- How to set keyable and non-keyable channels
- How to use Set Driven Key
- How to use Auto Key
- How to edit an animation's timing using the Dope sheet
Refining the animated channels

In the last lesson, the bouncing ball does not appear to bounce properly. It seems to float as it touches the ground instead of hitting hard as you would expect. To edit the quality of the bounce, you can use the Graph editor to work with the animation channels.

1 Select the ball
   If you are continuing straight from
   Lesson 1, the ball may already be selected.
   If not, then you must select this object to
   work with the animated channels
   - If the ball is not selected, then select
     it in one of the view panels

2 Create a new panel layout
   You can switch the contents of a panel to
   other panel types such as lists or graphs.
   - In the perspective view panel’s
     Panels menu, select Saved Layouts
     → Persp/Graph
     This places a perspective view panel
     above a Graph editor panel
   - Click-drag down on the bar that
     separates the two panels to make
     the new perspective panel larger
   - From the Graph Editor’s View
     menu, select Frame All
     Now you can see all of the
     animation curves for the ball
   Earlier, you set keys for the ball
   This set keys for all the Translate,
   Rotate and Scale attributes, in all
   three axes, as well as Visibility. Each
   of the animated attributes creates an
   animation curve that represents
   how each channel changes over time

3 Focus on the Translate Y channel
   To focus on the up and down motion of
   the ball, you need to focus on the Translate
   Y channel
   - Click on the Translate Y channel.
     Now only its curve is shown in the
     graph.
   - Press the Alt key and click-drag
     with the left and middle mouse
     buttons to dolly into the graph.
   - Press the Shift and Alt keys and
     click-drag up and down with the
     left and middle mouse buttons to
     dolly only along the Y-axis.
   - Press the Shift and Alt keys and
     click-drag up and down with the
     middle mouse button to track along
     the Y-axis
   - Use these tools to position the graph
     as shown below:

4 Edit the shape of the curve
   The floating effect as the ball touches the
   ground is a result of the smoothing of the
   curve as it approaches a value of 0.
   This smoothing is created by the curve
   tangents. The tangents define the motion in
   between the keys. By editing the tangents, you
   will change how the ball moves
   between the keys
   - Click-drag over all of the points at
     the bottom of the bounce to select
     the keys.
   - Press the Linear Tangents button to
     make the curve tangents meet at a
     point

5 Edit the tangents at the keys
   To accentuate the bounce even further, you
   can edit the actual tangents to make the
   curve steeper as it approaches the ground.
Lesson 2
Cleaning up your curves

- Press the Break Tangents button to break the connection between the opposite tangents at the key.
- Click-drag a selection box around the tangent handle on the first key.
- Make sure that you select only the tangent handle and not the key itself.
- Make sure that the Move tool is active.
- Click-drag with your middle mouse button to edit the curve's tangent until it is almost vertical and you don't get a bump at the next key.

Edited tangent handle

- Click-drag a selection box around the next key on the curve.
- This reveals the tangent handles for that key.
- Click-drag a selection box around one of the tangent handles.
- Edit the tangent using the middle mouse button to make it more vertical.
- Repeat the tangent edit for all of the other tangents until the curves appear as shown.

Diagram of edited bounce

The bounce is much more sharp and appears to be affected by gravity.

Cleaning up your curves

Now that the quality of the motion has been set, you can look for ways to clean up your animation curves so that unnecessary information is removed. For this scene, the extra curves will have little influence, but in larger scenes they can add up and affect performance.

1 Remove static channels

- If an action curve is flat along its whole length then its value is not changing. This means that it is not being animated.

Action curve with keys highlighted

- Playback the results in the Perspective view.

Static channels

- From the Graph Editor's Edit menu, select Delete.
- This removes the selected curves from your scene.

Note:
- In the Channel box, you will see that the remaining input fields – Translate X and Translate Y – use a different background color. This color helps you distinguish channels which have been keyed.

2 Remove extra keys

In some cases, you may have keys on animated channels that don't contribute to the results. These keys are found when a straight line can be drawn from the key before to the key after.

- In the name list, press the Ctrl/Command key and click on the following channel names:
  - Translate Z
  - Rotate X, Y and Z
  - Scale X, Y and Z
  - Visibility
  - The Translate X and Translate Y should remain unselected

Extra keys

- Press the Delete key to remove the keys.
- The resulting curve would now be easier to edit because there are no intermediate keys.
LESSON 2
Adding a squash deformer

SQUASH AND STRETCH
One of the best methods to infuse your animation with life is to add squash and stretch. This traditional animation technique helps you avoid a rigid looking animation as the ball hits the ground with more emphasis and seems to soar as it leaps into the air. In Maya, you can create this effect using a squash deformer.

Adding a squash deformer
A deformer is a special object type that lets you reshape a surface or group of surfaces. By using deformers to change the shape of the object over time, you can create a more visually appealing animation.

1 Set up a front view
  - Go to frame 1
  - This will place the ball at its starting point.
  - In the perspective view's Panels menu, select Panels → Orthographic → Front.
  - This gives you a view of the ball looking down the Z-axis.
  - Dolly and track the view until you are looking at the side of the ball.

2 Add the squash to the ball
  - Select the ball
  - Press F2 to go to the Animation menu set
  - From the Deform menu, select Create Nonlinear → Squash
  - This adds the squashHandle to the ball. You do not see any deformation yet since the squash attributes have not been edited.

3 Move and Scale the deformer
  - Move the squashHandle so that the manipulator is at the base of the ball.
  - Scale the squashHandle until the handle appears at the top of the ball.
  - Now the squash will occur from the base of the ball instead of in its middle. This ensures that the bottom of the ball doesn't leave the ground during the squash.

4 Test the squash's Factor attribute
  - In the Channel box, click on the squashInput node.
  - Select the Show Manipulator tool.
  - Click-drag on the middle manipulator handle to squash and stretch the ball.
  - When you are finished check the channel box and make sure that the Factor attribute is set to about 0.4 to give the ball a little stretch.

5 Test the playback of the ball
  - Dolly out of the view so that you can watch the whole bouncing motion
  - Playback the animation.
  - The ball animates but the deformation of the ball only works properly at frame 1. This is because the deformer is not moving with the ball.

6 Parent the deformer
To make the deformer move with the ball, you need to parent the deform handle to the ball:
  - Go back to frame 1
  - Select the squashHandle then press the shift key and select the ball.
  - Select Edit → Parent
  - You could also press the p key to parent the handle to the ball.
  - Playback the animation.
  - Now the deformer moves with the ball.

animating the parented nodes
Animate the squash

To animate the ball's squash and stretch, you could set keys, but if you later edited the timing of the ball's bouncing then these keys would have to be reset. For this reason, you will use a reactive animation technique called Set Driven Key.

This technique allows you to have one attribute drive another attribute. Since you know that you want the ball to squash when it touches the ground and stretch when it is in the air, you can use the ball's Y translation to drive the squash's factor attribute. Therefore, if you later edit the timing of the ball's bouncing or change its Y translation, the squash will react appropriately and squash on cue.

1 Load the Set Driven Key window

The Set driven key window lets you choose which attribute will be the driver and which attribute(s) will be driven.

- From the Animate menu, select Set Driven Key → Set - 3 to open the Set Driven Key window.

   When you want to open an option window, you need to select the menu item then move your cursor over the square icon.

   - Select the ball.
   - Click on the Load Driver button in the Set Driven Key window.
   - In the right hand column of the Driver section, click on translate Y.

   This sets up translate Y as the attribute that will drive the action.

2 Key the initial position

- Go to frame 1.
- Again highlight the squash input node in the Channel box.
- Set the squash node's factor attribute to show the ball in a squashed position.
- The image below shows a value of about -0.5.
- You can either use the Channel box or the Show Manipulator tool.
- Click on the Key button in the Set Driven Key window.

3 Key the second position

- Go to frame 30.
- Set the squash node's factor attribute to show the ball in a stretched position.
- Click on the Key button in the Set Driven Key window.

4 Edit the Animation curve

- Select the squashHandle.
- From the editor's View menu, select Frame all.
- The smaller of the two curves on the graph maps the ball's translate Y attribute to the squash's factor attribute.
- Select this curve and select View → Frame Selection.
- Edit the curve as shown in the following image.
**Lesson 2**

_Bending the ball_

2 **Parent the deformer**

To make the deformer move with the ball, you need to parent the deform handle to the ball.

- From the **Window** menu, select **Outliner**.
  This window offers you a listing of all the objects in the scene.
- With your middle mouse button, drag the **bendHandle** onto the ball node.

3 **Key the bend node's curvature**

The bend node has an attribute called curvature that is used to control how much bending will occur. This is the attribute that you will set keys on in order to animate the bending of the ball:

- In the **Channel box**, click on the **bend** input node to open it up.
- Click on the **Curvature attribute's name** to highlight it.
- From the **Channel box's Channels menu**, select **Key Selected**.
  This sets a start key for the curvature attribute.

4 **Turn on Auto Keying**

To set more keys for the curvature, you will use **Auto key**. This method of keying lets you set keys by simply changing the attribute value.

- Turn on **Auto Key**.
  Now when you update an attribute that has existing keys, a key will be set automatically.

5 **Edit the bend's boundary**

- Go to frame 1.
- Make sure that the **bend input node's name** is highlighted in the channel box.
- Select the **Show Manipulator tool**.
  This tool displays some handles that let you edit the attributes of the bend deformer. This gives you interactive control over the deformer's attributes.

6 **Edit the curvature**

- Click drag on the top manipulator to extend the **high bound** of the deformer.
  This will ensure that the bending works properly when the ball is fully stretched.

---

_Bending the ball_

**Edited animation curve**

- Playback the animation.
  You can see that there is a little more emphasis on the point where the ball hits the ground.

**Bending the ball**

As the ball goes into and out of a bounce, it might be helpful to have it lean forward as it bounces up and lean back as it hits. You can do this with a second deformer. This time you will use a **bend deformer**.

This will help give the appearance that the ball is propelling itself forward each time it hits the ground. This will give the ball a life of its own as it bounces along.

**1 Add a Bend deformer**

- Go to frame 1.
- Select the ball.
- From the **Deform menu**, select **Create Nonlinear → Bend**.
  Just like the Squash deformer, the Bend adds a bendHandle and a bend node to the ball. The bendHandle node is currently highlighted.

- Close the outliner window.

---

**Learning Maya**

50

**Learning Maya**

51
7. Set another key
   - Go to frame 15
   - Drag to the left on the center manipulator handle to bend the ball back. This will set the node's curvature to about -0.6. Another key is set by Auto Key.

8. Continue animating the bending
   - Use the Auto key method to set new keys for the bend node's curvature so that the ball bounces forward at frames 25 and 45 and back at frames 35 and 55.
   - Go to frame 60 and change your curvature to 0.
   - Change the front view panel back to a perspective panel.
   - Playback the results.

Editing timing

To give the impression that the ball is pushing off as it bounces, you will have to edit the timing of the bend action. The goal is to move the bend action closer to the bounce of the ball to make it appear more immediate.

You can edit the timing of your keys in the Graph editor:

Earlier, you edited the quality of the animation using the Graph editor. To edit the timing of the bouncing, you can also use the Dope sheet. The Dope sheet lets you focus on timing without having to look at all of the curve information.

1. Select keys in the Dope sheet
   - Make sure the bendHandle node is selected and the bend node is not highlighted in the Channel box.
   - In the Graph editor, panel's Panels menu, select Panel → Dope Sheet.

   This window shows each channel as a series of ticks on a long bar which represent frames. Some of these are highlighted with color bars that show you where keys have been set.

   The top bar shows a summary of the keys while each channel of the selected nodes has its own bar.

   - Click on the plus sign next to the bendHandle node that is in the square.
   - Click on the second plus sign next to the bendHandleShape node that is in the circle.
   - With the left mouse button, click on the key at frame 15.

   It will be the only key highlighted in yellow.

   - Press the Shift key and click with the left mouse button on the keys at frames 25 and 35.

2. Move the bend handle keys
   - Select the Move tool.

   - With the middle mouse button, click-drag to the right in the Dope sheet until the first key is at about frame 19.

3. Edit the shape of the curve
   - While editing the timing of the bending in the dope sheet helps a bit, you may not be getting the look that you want. To edit how the curve reacts between the keys, you can edit the shape of the curve in the Graph editor.

   - In the Dope Sheet's Panels menu, select Panel → Graph Editor.

   Use the techniques learned earlier in the lesson to reshape the curve as shown below.

   - Playback the results.

4. Save your work
   - From the File menu, select Save Scene As.

   - Enter the name bounce_2 next to the file's path.

   - Press the Save button or press the Enter key.

Tip:

It is a good idea to give your file a new name after significant changes have been made. The different files give you a record of past stages in case you want to go back. Once you have saved a few versions, you can clear earlier files to help conserve disk space.
Conclusion
You have now added some character to the bouncing ball. In the next lesson, you will learn how to texture and light your scene in order to begin creating rendered animations. If desired, you could now use the Dope sheet or the Graph editor to further refine the quality and timing of the various channels to achieve a bounce with different kinds of character. You might want the ball to bounce higher or the bending to be more subtle.
This refinement is ultimately your role as an animator. While the actual work of setting keys is finished, you will find that the refinement stage could become the most time-consuming, and yet the most rewarding. Since this book is focused on technique, the refinement will be left up to you to add at the end of each lesson.

Rendering

Now that you have animated the ball, you are ready to render the scene. The rendering process involves the preparation of shaders and textures for your objects and the manipulation of cameras and lights. You can add effects such as motion blur to accentuate the motion during playback of the rendered frames.

Software rendering of the ball

In this lesson you will learn the following:
- How to work with a menu-less user interface
- How to work with the Hypershade panel
- How to create a shading group
- How to texture map an object
- How to add lighting to your scene
- How to test render a single frame
- How to set up motion blur
- How to software render an animation
LESSON 3
Hiding the general UI

In the last two lessons, you used menus, numeric input fields and other user interface elements to work with your scene. In this lesson, you will hide most of the user interface and rely more on the hotbox and other hotkeys that let you access the UI without actually seeing it on screen.

1 Turn off all of the menus
   - Move your cursor over the Perspecrve view panel, then press the spacebar to quickly pop this panel to full screen
   - Press and hold on the spacebar to evoke the hotbox

   Tip: Tapping and holding down the spacebar, respectively, can be used to both toggle between window panes and to bring up the hotbox

   - Click on the Hotbox Controls
   - From the marking menu, go down to Window Options and set the following:
     (Windows only) Show Main Menu Bar to Off
     Show Pane Menu Bars to Off

2 Turn off all of the workspace options
   - From the hotbox, select Display → UI Elements → Hide UI Elements.

3 Change the panel organization
   - Press and hold on the spacebar to evoke the hotbox
   - Click in the area above the menus to invoke a marking menu
   - Select Hypershade/Render/Persp from this marking menu

Now the various menus are hidden and you must rely on the hotbox to access tools.

4 Open the Attribute Editor
   - From the hotbox, select Display → UI Elements → Attribute Editor

   Now you also have an Attribute editor panel on the right side of the workspace. This will make it easy to update shading group attributes.

Tip: Each of the four quadrants surrounding the hotbox and the hotbox's center all contain their own marking menu set.
You can edit the contents of these menus using Window → Settings/Preferences → Marking Menus.

This saved layout puts a Hypershade panel above a Perspective panel and a Render view panel.

The Hypershade is where you will build shading networks and the Render view is where you will test the results in your scene.

4 Open the Attribute Editor
   - From the hotbox, select Display → UI Elements → Attribute Editor

   Now you also have an Attribute editor panel on the right side of the workspace. This will make it easy to update shading group attributes.

Hotkeys
When working with a minimal UI, you will rely on the hotbox and hotkeys for your workflow.
The following is a list of relevant hotkeys that you may need to use as you work:

Spacebar: hotbox/window popping
Alt v: Start/stop playback
Alt + Shift v: Go to first frame
Alt +: Move one frame forward
Alt -: Move one frame back
k: Click-drag to scrub animation

If you have selected an animated node such as the ball, then you can also use the following hotkeys:
- Go to next key
- Go to last key

For a complete listing of available hotkeys, go to Window → Settings/Preferences → Hotkeys...
SHADING GROUPS

To prepare the ball and the floor for rendering, you need to add color and texture. In Maya, this is accomplished using shading groups that bring together material qualities, textures, lights, and geometry to define the desired look.

The Hypershade panel

The Hypershade panel is made up of three sections—the Create bar, the Hypershade tabs, and the Work area. The Create bar allows you to create any rendering nodes you require for your scene. The Hypershade tabs list all nodes that make up the current scene while the Work area allows you to look more closely and alter any part of the shading network that is used to create a shading group.

1. Create a material for the ring
   To build a material for the ring, you will use the Hypershade and the Attribute Editor:
   - Click with your right mouse button in the work area and select Graph → Clear Graph.
     This clears the workspace so that you can begin working on a new shading network.
   - In the create bar section, click on the Create menu bar at the top of the create bar window. From the pop-up select Create Materials.
     This offers you a series of icons that represent new materials.
   - Click on Blinn.
     This adds a new blinn material under the materials hypershade tab and in the work area. You will also see the Attribute Editor update to show the new nodes information.

Creating a shading group

A shading group is made up of a series of nodes which input into a shading group and material nodes. In the following examples, you will create several nodes that define the material qualities of the ring and the floor.

2. Rename the material node
   - In the Attribute editor, change the name of the material node to ringM.
     The M designation is to remind you that this node is a material node.

3. Edit the material's color
   - To define how the material will render, you will need to set several key material attributes such as color.
     - In the Attribute editor, click on the color swatch next to the Color attribute.

4. Assign the material
   - With your middle mouse button, click-drag on the ringM node and drag it from the Hypershade panel into the perspective view and drop it on the ring.
     This assigns the material to the object.

Creating a texture map

To give the floor a pattern, a grid texture will be added to the floor material's color. This will
be accomplished using the drag and drop capabilities of the Hypershade.

1. Create a material for the floor
   To build a textured material for the floor, you will use the Hypershade panel to build up the material using a grid texture.
   - In the Hypershade clear the work area by holding down the right mouse button and selecting Graph → Clear Graph.
   - In the create bar section, click on the Phong.
   - In the Attribute editor, change the name of the material node to floorM.

2. Create a checker texture
   - In the create bar section, click on the Create Materials bar and from the pop-up menu select Create Textures.
   - This offers you a series of icons that can be used to create new textures.
   - Select Grid from the menu.
   - From the Work area, click with your MMB on the Grid icon and drag it onto the floorM material node in the work area of the Hypershade.
   - Release the mouse button.
   - A pop-up menu appears offering you a number of attributes that can be mapped by the checker texture.
   - Select color from the menu to map the grid to the material node's color attribute.

3. Assigning the material
   You will assign the texture map to the floor and then use hardware shading to preview it.
   - With your middle mouse button, click on the floorM material node and drag it onto the floor surface in the perspective view.
   - Move your cursor over the Perspective window and click with your middle mouse button to make it the active window.
   - Invoke the bottom and select Shading → Hardware Texturing.

4. Edit the grid attributes
   - In Hypershade, click on the grid node.
   - In the Attribute Editor, click on the color swatch next to the Line Color attribute.
   - Choose any color you want then click the Accept button.
   - Click on the color swatch next to the Filter Color attribute.
   - Choose any color you want then click the Accept button.
   - Change the grid’s width attributes as shown below:
     - U Width to 0.75.
     - V Width to 0.75.
   - The Attribute editor allows you to easily update the look of a procedural texture.

5. Display the whole shading group
   - With the grid texture highlighted in the Hypershade, go to the second last button of the window and click on the Input and Output Connections button.
   - This displays some other nodes that help define this shading group.
   - Press the Alt key then click-drag with your left and middle mouse button to zoom out.

Tip: You can also turn on hardware texturing by making the desired panel active and pressing the 0 key.

Hardware texturing

New Grid

Input and Output Connections

Complete shading network

Learning Maya
Lesson 3
Creating a ball material

6 Edit the texture’s positioning
   The placement of a texture on a surface is defined by the place2DTexture node:
   • Click on the place2DTexture node to highlight it.
   • In the Attribute editor, change the following attributes:
     Repeat U to 8
     Repeat V to 8

1 Create a material for the ball
   • From the Hypershade panel’s work area right-click with the mouse and select Graph → Clear Graph
   • Re-select the Create Material menu and select Phong
   • Rename this node ballM

2 Create a file texture node
   To load an external texture, you need to start with a file texture node:
   • In the Attribute editor, click on the Map button next to Color. The map button is shown with a small checker icon.
   • This opens the Create Render node window.
   • Click on the Textures tab in the 2D Textures section, then click on File.
   • A file node is added to the phong material. All the appropriate connections have already been made.

3 Import the file texture
   • In the Attribute editor, click on the File folder button next to Image name.
   • Select the file names face if then click on the Open button.
   The file texture is now loaded into the shading network.

Tip: This method of assigning materials works better than the click-drag method when you want to assign a material to multiple objects.

Positioning the texture

You will create a material for the ball that uses a file texture instead of a procedural texture. Many digital artists like to create textures in a 2D paint package. For the ball, you will use a painted texture of a face.

4 Apply the material to the ball
   • Select the ball in the perspective view.
   • In the Hypershade, click on the ballM node with your right mouse button and choose Assign Material to Selection from the pop-up menu.
   The texture is assigned to the ball but it doesn’t seem to be positioned correctly. You will correct this using the placement node.

1 Change the texture’s rotation
   • Click on the file texture node’s place2DTexture node. This will bring it into the Attribute Editor.
   • In the Attribute Editor, set the following attribute:
     Rotate UV to 90
   If you are using hardware texturing, you can see the file texture is now oriented properly on the ball’s surface but it is facing the wrong way.

Note: This file will be available only if you set up your project as indicated at the beginning of Lesson 1.
LESSON 3
Placing a spot light

way. This is because the ball’s seam is facing forward. You need to offset
the texture.

Render → Render → persp from the
pop-up menu.
You can now see a rendered image of
your scene. However because
you have not created any lights the
image renders using a default light

LIGHTING
In the real world, it is light which allows us to
see the surfaces and objects around us. In
computer graphics, digital lights play the
same role. They help define the space within
a scene, and in many cases help to set the
mood or atmosphere.

Placing a spot light
To create the primary light source in the
scene, you will use a spot light. This light
type lets you define important attributes such
as the light’s cone angle and its intensity.

1 Create a spot light
- Press F5 to go to the rendering
  menu set.
- Click on the perspective view panel
  with your middle mouse button
  then press the spacebar quickly to
  pop to a full view.
- From the hotbox, select Create →
  Lights → Spot Light.
  This places a spot light at the origin.

2 Test Render the scene
Now that you have the textures ready, it
would be a good time to do a test
rendering.
- In the Render view panel, click with
  your right mouse button and select

3 Turn on hardware lighting (if possible)
One step beyond hardware texturing is
hardware lighting. This lets you see how the
light is affecting the surface that it is
shining on.
- From the hotbox, select Lighting →
  Use All Lights. You could also use
  the 7 key.

At first you may not see much
lighting on the surface. You need to
update the floor’s subdivisions.
- In the Perspective window, click
  and hold with the right mouse
  button on the floor object.
  This node now displays in the
  Attribute editor.
- Set the following attributes:
  Subdivisions Width to 20;
  Subdivisions Height to 20
The spot light’s cone of illumination
can now be seen on the surface of
the floor.

Note: You only need to increase the
subdivisions for a hardware texturing
preview of the scene. If you are software
rendering, then one subdivision in each
direction should work fine.

4 Edit the spot light’s cone angle
You can now edit some of the light’s
attributes to control its effect. You will

64 LEARNING MAYA
Lesson 3
Placing a Spot Light

1. View through the light
   It is sometimes difficult to position a light when standing beside the scene. In Maya,
   you can also look through the light to aid in positioning.

   - Click with your middle mouse button over the perspective view panel to make it active.
   - Using the hotbox, select Panels → Look Through Selected.

   You are now looking at the scene from the light's point of view. The Cone Angle
   manipulator is still available for you to click-drag.

   - Click-drag on the cone angle manipulator to illuminate more of the scene.

   In the Attribute editor, you can watch the Cone Angle attribute update as you click-drag.

2. Reposition the light
   You can now use the view change tools to edit the position of the light.

   - Press the Alt key to tumble, pan and dolly into the view.

   Work with these tools until you see a view similar to the view shown below.

3. Adjust the penumbra angle
   To get some softness at the edge of the spotlight, you can adjust the light's penumbra.

   - In the Attribute editor, set the Penumbra Angle to 5.

   You can now see a second circular line outside the cone angle icon that indicates the area
   where the light will be soft.

4. Rendering the scene
   Now that you have a light in your scene, you can turn on shadow casting and then create a test
   render. This will let you see a higher quality image of a still frame.

5. Return to Perspective view
   - Middle mouse click in the perspective view panel to make it active.
   - Using the hotbox, select Panels → Perspective → persp.

   You are now looking at the scene from your old point of view.

   Tip: You can click-drag lights and cameras from the Outlines to any view panel.

6. Playback the animation
   - Use the view tools to center the action within the view panel.

   - Playback the animation using the necessary hotkeys to see how it looks with hardware lighting.

New spot light view

New angle of view

Spot light view
1 Turn on depth map shadows
In Maya, shadows are turned off by default for each light. This allows you to turn shadows on for only those lights that require shadows
- Select the spot light
- In the Attribute Editor, open the Shadows section and click on Use Depth Map Shadows
Leave the default settings. They will be explained in more depth in a later lesson.

2 Set Render Globals
The Render Globals are a set of global attributes that you can set to define how your scene will render. To set up the quality of the test rendering, you need to set the Render Globals
- Quick tap with the space bar in the perspective window to go back your original Persp/Hypershade/Render View layout. In the Render View panel, click with your right mouse button and choose Options → Render Globals...
- Select the Maya Software tab
- Open up the Anti-aliasing Quality section.
- Set the presets to Intermediate Quality
Anti-aliasing is a visual smoothing of edge lines in the final rendered image. Because bitmaps are made up of square pixels, a diagonal line would appear jagged unless it was somehow anti-aliased
- Close the Render Globals window

3 Display resolution gate
Your current view panel may not be displaying the actual proportions that will be rendered. You can display the camera's resolution gate to see how the scene will actually render
- Make the Perspective view the active panel
- Use the hotbox to select View → Camera Settings → Resolution Gate.
The view is adjusted to show a bounding box that defines how the default render resolution of 320 x 240 pixels relates to the current view
- Dolly into the view so that it is well composed within the resolution gate. Try to set up a view where the ball starts in the back of the scene then animates to the front
Keep in mind that only objects within the box will be rendered
- Playback the animation to confirm that the scene works for the whole sequence. If not, then edit the view until you are happy with the camera setup

4 Test render the scene
- Select Display → UI Elements → Time Slider
- Go to frame 30
- In the Render View panel, click with the right mouse button and choose Render → Render → persp.

5 Zoom into the rendering
You can view the rendering using the Alt key and the zoom and track hotkeys
- Use the Alt key and the left and middle mouse buttons to zoom in to the view.
Now you can evaluate in more detail how your rendering looks at the pixel level

Rendering animations
Once you are happy with your test rendering, it is time to render an animation. This will be accomplished using Maya's batch render. In preparation, you will add motion blur to your scene to simulate the blur generated in live action film and video work

1 Set the Image output
To render an animation, you must set up the scene's file extensions to indicate a rendered sequence. You must also set up the Start and End Frames
- From the Hotbox, select Window → Rendering Editors → Render Globals...
- Select the Common tab
- From the Image File Output section, set the following:
  - File Name Prefix to bounce;
This sets the name of the animated sequence
LESSON 3
Rendering animations

Frame/Animation Ext
name.f.txt (for Windows, Mac)
name.utx (for IRIX).
This sets Maya up to render a numbered sequence of images.
Start Frame to 1;
End Frame to 60;
By Frame to 1
This tells Maya to render every frame from 1 to 60

This type of motion blur renders the fastest.

Motion blur check box

3 Save your work
- From the File menu, select Save Scene As...
- Enter the name bounce_03 next to the file's path
- Press the Save button or press the Enter key.

4 Batch render the scene
- Press F5 to change to the Render menu set
- Use the hotbox to select Render ➔ Batch Render

5 Watch the render progress
The sequence will be rendered as a series of frames
- Use the hotbox to select Window ➔ Editors ➔ Script Editor.
In this window, you can watch a series of status entries for your animation

6 View the resulting animation
After the rendering is complete, you can preview the results using the fcheck utility
On Windows, Mac
- Open the fcheck utility by clicking on its icon.

Conclusion
You have now touched some of the basic concepts in texturing and rendering a scene.
Maya's shading groups offer a lot of depth for creating the look of your scenes. In later lessons, you will learn how to make use of some of this power.
The resulting animation shows a ball with a texture map of a face. In the next lesson, you will use particles to create a ring of fire that helps explain the concerned look on the ball's face.

Tip:
To learn more about the capabilities of fcheck for previewing your animations, enter fcheck -h in a shell window.
Particles

Particles are small object types that can be animated using dynamic forces in place of traditional keyframes. These effects are in essence simulations of physical effects such as water, smoke and fire.

To add particle effects to the scene, you are going to add flames to the ring. These flames will be created using Maya's default particle fire effect. You will then create sparks that will be animated to appear when the ball touches the fire.

In this lesson, you will learn the following:

- How to add a fire effect to a NURBS torus
- How to collide the ball and the flames
- How to set up a particle event
- How to define a particle attribute using a ramp
- How to define a particle attribute using an expression
- How to software render a particle animation
- How to hardware render a particle animation
Lesson 4
Project set-up

Project set-up
If you are continuing from the last lesson, then you can begin working right away. If not, then open the Maya file you saved in that lesson. You will continue to use the menu-less user interface to explore the use of hotkeys and the hotbox.

1 Set up your Perspective panel
To simplify the workspace, you will focus on a single Perspective view. You will also turn off the resolution gate to let you focus on the particles.
- Use the spacebar to make the Perspective view panel full screen
- Select View → Camera Settings → No Gate to turn off the resolution gate.

2 Change menu sets
- Press h and click with the left mouse button. Choose Dynamics from the marking menu.

Note: You could have also used the F4 hotkey to change menu sets.

Ring of Fire
Using one of Maya's preset particle effects, you will add fire to the ring. This preset creates everything needed to make the particles act and look like fire.

1 Adding the Fire Effect
- Select the ring torus
- Select Effects → Create Fire

2 Playback the simulation
- Select Display → UI Elements → Range Slider
- Click the Animation Preferences button found at the right side of the Range slider
- In the Playback section, set the following:
  - Playback Speed to Play Every Frame.
When working with particles it is very important that the playback speed is set to play every frame. Otherwise, your simulations may act unpredictably.
- Click the Save button
- Go back to frame 1 and playback the simulation.

The particles are generated from the ring. The simulation plays back at the same time the ball is animating. In Maya, you can combine animated objects with your particle simulations.

Default fire particles
The fire effect is the result of a particle object that is controlled by several dynamic fields such as gravity and turbulence. The fire preset adds these elements to your scene and lets you easily control them.

3 Editing the fire attributes
To control the various parts of the fire effect, you can simply edit attributes that are designed specifically for the fire effect.
- Playback the simulation to a point where particles are visible then stop.
- Select the fire particles
- In the Attribute editor, make sure that the particleShape tab is pressed.
- Rename the particles flame.
- Scroll down to the bottom and open the Extra Attributes section.
- Set the following attributes:
  - Fire Density to 15;
  - Fire Lifespan to 1.5
- Go back to frame 1 and playback the simulation.

Now there are more fire particles and they last longer.

4 Setting the initial state
One problem you may notice with the simulation is that there are no particles when the animation starts. Since the ring of fire needs to be lit at all times, you must set the particle's initial state.
- Playback the scene until around frame 35 then stop playback.
- Select the particles.
- From the Solvers menu, select Initial State → Set for Select.
- Go back to frame 1 and playback the simulation.

By setting the initial state for the particles, you can see that at frame 1, the particles are already created.

5 Test render the particles
- Playback the scene until around frame 35 then stop playback
- Press F5 to go to the Rendering menu set
- From the Render menu, select Render current frame...
LESSON 4
Sparks

The scene is now rendered with the fire particles included. Some particles can be rendered using the software renderer which allows them to be automatically integrated into the scene.

Software rendering

Note: The flame's shadows don't look very convincing because the depth map shadows don't work well with the fire's volumetric shades. Also, there is a strange halo around the fire that is caused by the 2D motion blur. You will fix these problems later in the lesson.

Sparks
An added effect you will set up more particles that will represent emitted sparks when the ball touches the flames. You will set up this effect to occur at exactly the point where the ball touches the flames.

1 Set up particle collisions
To make the ball and the particles collide, you must define them as colliding objects.

- Select the flame particles

- Press the Shift key then select the ball

Note: It is very important that the ball is selected last.

- Press F4 to go back to the Dynamics menu set then from the Particles menu, select Make Collide

2 Preview the results
- Select Panels → Orthographic → front
- Playback the simulation

When the ball collides with the flames they are pushed a little forward.

- Mininal collisions

3 Adding friction
- Select the fire particles on their own
- In the Attribute editor, click on the geoConnector tab.
- Set the following attributes:
  - Resilience to 0.3;
  - Friction to 0.9
- Playback the simulation

Now the flames react a little more when they collide with the ball. The lower resilience allows them to react more and the friction is allowing the ball to drag the flames forward.

- Stronger collisions

4 Create a Particle Event
To generate the sparks, you will use the Collision between the ball and the flames to emit a new particle object

- Select the fire particles
- From the Particles menu, select Particle Collision Events...

5 Add Gravity to the particles
- Select the new particles
- From the Fields menu, select Gravity

In the Particle Collision Events window, go to the Event Type section and set the following:

- Type to Emit;
- Random # Particles to On;
- Num particles to 6;
- Spread to 0.2;
- Inherit Velocity to 0.8

- Click Create Event and close the Particle Collision Events window
- Playback the simulation

Several small particles are emitted after the ball touches the flames. These particles float forward based on the momentum they received from the collision. Now you will adjust how they react and how they look.

- Stop at a frame where the new particles are visible

LEARNING MINS 77
LESSON 4
Designing the look of the sparks

- In the Attribute editor, set the Magnitude to 25
  This will make them drop more quickly
- Playback the simulation
  Now the particles drop to the ground after the collision. The gravity field is pulling them down

Designing the look of the sparks

To create particles that look like sparks, you need to adjust various particle attributes. In this case, you will create particles that will be streaks that die fastly quickly after being emitted. Their color will start out white, and then turn to a yellow-orange.

1 Change Render Type to streak

Particles can have their render type set from a list of possible looks. You can switch between the different types until you get one that suits your needs
- Select the new particles
- Rename them sparks
- In the Attribute Editor, go to the Render Attributes section and set Render Type to Streak

2 Add and edit render attributes

- Click on the Current Render Type button
- Set the Render Attributes as follows:
  Line Width to 1,
  Tail Fade to 0.67,
  Tail Size to 3.0
  This gives the sparks a much stronger presence. The higher tail fade value means that it doesn't taper off too strongly and the tail size value lengthens the sparks.

3 Add color per particle

The particle node has the ability to have new attributes added to it as they are needed. This lets you add complexity to a particle node when you need to.
You can use this technique to add color to the particles that will affect the particles individually instead of as a group
- In the Add Dynamic Attributes section, click on the Color button
- From the Particle Color window, select Add Per Particle Attribute then click the Add Attribute button
  This adds a rgbPP line to the Per Particle Attributes section
- Click on the rgbPP field with your right mouse button and select Create Ramp
  Click again on the rgbPP field with your right mouse button and select arrayMapper.outColorPP -> Edit Ramp
  In the Ramp window, you will find three markers each with a square and a circular icon
  Click on the circle icon at the bottom of the ramp then click on the color swatch next to Selected Color
  Change the color to white
  Complete the same steps to change the middle marker to a yellow and the top marker to a yellow-orange.

4 Particle Lifespan and Randomness

The Lifespan attribute lets you determine how long the particle will remain in the scene before it appears or dies. You will then add a slight randomness to the lifespan of the particles
- With sparks selected, go to the Lifespan Attributes section in the Attribute editor
- Change Lifespan Mode to Random range
- Change the Lifespan to 0.4
- Change the Lifespan Random to 0.25
  The lifespan is uniformly distributed with lifespan as the mean and lifespan Random as the width of the distribution.
Therefore the particles in this case have a lifespan between 15 and 65. This gives the sparks a more random look.

5 Save your work
- From the File menu, select Save Scene As...
- Enter the name bounce_04 next to the file's path
- Press the Save button or press the Enter key.

Rendering Particles

The question, therefore, is how do you bring hardware rendered particles together with software rendered scene?

The answer is to render them separately, and then bring them together using a compositing package.

To composite the particles with the ball, you will need to render the top layer – in this case the sparks – with a matte or mask.
The mask is a grayscale channel that defines where areas to be masked out when layered on top of the background. In this scene, the background is the bouncing ball, the ring of fire, and the floor.

Software rendering

The flames created using the fire effect can be rendered using software rendering. This means creating another batch rendering of your scene. This will represent the first render pass that can then be later composited together with the sparks.

1 Change your motion blur type
Since the 2D motion blur used in the last lesson doesn’t render well with the flame particles, you will switch to the 3D motion blur type.
- Select Window → Rendering Editors → Render Globals
- Open the Motion Blur section and change the Motion Blur Type to 3D.
   This type of motion blur renders more accurately but is more accurate and works better with software rendered particles.

2 Fix the flame shadows
Earlier it was noted that the shadows generated from the flames didn’t look correct. The depth map shadows can not recognize the subtleties of the volumetric shader used for the flames and raytrace shadows are needed.
- Select the spotlight that is illuminating the scene
- In the Attribute editor, open the Shadows section, scroll down to Raytrace Shadow Attributes and set Use Ray Trace Shadows to On
- Set the Ray Depth Limit to 2
   This sets up the light, but to use raytraced shadows, you will need to turn on ray tracing itself.
- Open the Render Globals
- Open the Raytracing Quality section and turn Raytracing to On

Note: Maya uses a selective sraytracer and only objects that require reflections, refractions or ray trace shadows will use this technique.

3 Limiting the Reflections
When Raytracing is turned on, any shader that has a reflectivity value will render with reflections. It is therefore a good idea to set Reflectivity to 0 for some objects so that the rendering be as fast as possible.
- Open up a Hypershade panel
- Select the ball, the floor and the ring in the perspective view
- In the Hypershade, use the hotbox to select Graph → Graph Materials on Selected Objects
- Select the ballM material node in the work area.
- In the Attribute editor, go to the Specular shading section and set Reflectivity to 0
   Now the ball won’t reflect anything
- Set Reflectivity to 0 for the ring
- Set Reflectivity to 0.33 for the floor so that you do see some reflectivity in the scene.

4 Re-size of the floor surface
- To make the floor larger so that it extends beyond the spotlight’s influence, you will scale it out then update its texture placement to match the new size.
- Select the floor surface.
- In the Attribute editor, set the following:
  Scale X to 4;
  Scale Y to 4;
  Scale Z to 4

Note: The three columns in the Attribute Editor represent X, Y, Z
- In the Hypershade, select the floorM shader
- Click on the Input connections button
- Click on the plaz2DTexture node
- In the Attribute editor, set the following:
  Repeat U to 32;
  Repeat V to 32.

5 Batch render the scene
- Select File → Save Scene as...
Hardware rendering

You have been using hardware rendering in the Perspective view panel to help preview the scene. You can also use hardware rendering to render the spark particles so that they match the rendered scene.

1. Set the opacity of the fire
   Since you only want the sparks to appear in the hardware rendering, you will need to hide the flames by setting an opacity value to 0.
   - Select the flame particles.
   - In the Attribute editor, scroll down to the Add Dynamic Attributes section and click on Opacity.
   - Choose Add Per Object Attribute then click on the Add Attribute button.
   - This adds an opacity attribute to the Render Attributes section.
   - Set Opacity to 0.
   Now the particles will not be visible in the hardware rendering. You can set opacity to 0 when you want to hardware render the scene and to 1 when you want to software render the scene.

2. Set the hardware render attributes
   - Select Window → Rendering Editors → Hardware Render Buffer.
   - In the Hardware Render Buffer window, select Render → Attributes.
   - In the Attribute editor, set the following attributes:
     - Filename to sparks
     - Extension to name.1.ext (Windows, Mac)
     - or to name.ext.1 (IRIX)
   This should match the extension setting you chose for your software rendering.
   - Start Frame to 1;
   - End Frame to 60;
   - Resolution to 320x240;
   - This sets the length and size of the animation.
   - Alpha Source to Luminance;
   - Geometry Mask to On
   This will use the ring, floor and the ball as mask objects and the particle luminance to define the alpha. An alpha channel, otherwise known as a matte channel, is important for layering images in a compositing package later.

3. Test a frame
   - Playback the simulation until you hit a frame where some of the sparks appear.
   - Click on the Test button in the middle of the Render Buffer’s time controls.

4. Render a sequence
   You can now render a whole animation using this window. Compared to software rendering, this window lets you use the speed of hardware rendering to generate animations quickly.
   - Select Render → Render Sequence.

5. Preview the resulting flipbook
   Once the sequence is complete, you can preview the results.
   - Select Flipbooks → sparks 1-60

6. Composite rendered animations
   You now have an animation of a bouncing ball and a sequence of particles embedded with an alpha channel. You can now use your compositing software to layer all the elements together.

Tip: The resolution gate must be off when performing a hardware render if it is to be composited with the batch render.
The next chapter is a more in-depth look into some of the user interface elements that you have been using in these lessons. Once you have read this chapter, you will be able to make your own decisions on how you want to configure the UI for your needs.

In the projects that follow, the instructions will not specify whether or not you should use the hotbox or menus to complete an action. The choice will be left up to you.

There are several advantages to compositing your layers instead of rendering them all into one scene:

- by separating background and foreground elements and rendering them individually, rendering times can be greatly reduced;
- by rendering different elements on different layers, it is easier to later make revisions to one layer without having to re-render the whole scene;
- when working with particles, interesting effects can also be achieved by compositing hardware and software rendered particles; and
- by using different layers, you can use your compositing software to adjust the color for a particular layer without affecting other layers.

Conclusion

Congratulations, you now have a complete scene that includes objects, shaders and visual effects. You have also begun to develop skills that you will use throughout your use of Maya.

If you have just completed the first four tutorials, then you have worked with Maya from modeling and animating to rendering and particles. Now is a good time to review some of the user interface concepts that you have worked with to give you a more complete overview of how Maya works.

It is recommended that you work through this chapter before proceeding with Learning Maya. This chapter explores the basic user interface actions that you will use in your day-to-day work.

The Workspace

You have learned how to build and animate scenes using different view panels and user interface tools. The panels offer different points of view for evaluating your work — such as perspective views, orthographic views, graphs and Outliners — while the tools offer different methods for interacting with the objects in your scene. Shown below is the workspace and its key elements:
LESSON 5
Layouts

When Maya is first launched, you are presented with a single Perspective view panel. As you work, you may want to change to other view layouts.

A four view layout

Tip: If you are looking at several view panels at the same time and you want to focus on one of them, tap the spacebar and the view will become full screen. Tap the spacebar again and the panels will return to the previous layout.

View panels
As you begin to build and animate objects, you will want to view the results from various points of view. In Maya, you can place either perspective or orthographic views in each panel.

To change the content of a view panel:
* Go to the view panel’s Panels menu and select a view type from either the Perspective or Orthographic pop-ups.

View tools
When you are working with perspective and orthographic views, you can change your view point by using hotkey view tools.

To tumble in a Perspective view:
* Press the Alt key and click-drag with the left mouse button

Tip: The ability to tumble an orthographic view is locked by default. To unlock this feature, you need to select the desired orthographic view and open the Attribute Editor.

To track in any view panel:
* Press the Alt key and click-drag with the middle mouse button

To dolly in any view panel:
* Press the Alt key and click-drag with both the left and middle mouse buttons.

The workspaces below you see a Hypershade panel for helping you organize your shading groups and a Graph Editor for working with animation curves.

The workspace with various panel types

Saved layouts
As you become more familiar with Maya, you may want to set up an arrangement of panels to suit a particular workflow. For example, you may want a Dope sheet, a perspective view, a Top view and a Hypershade view all set up in a particular manner.

Other panel types
You can also change the content of the view panel to display other types of information such as the Hypershade or the Graph Editor.

To change the content of a view panel:
* Go to the view panel’s Panels menu and select a panel type from the Panel pop-up.
LESSON 5
Display options

To add a new layout of your own:
- Go to the view panel's Panels menu and select Saved Layouts → Edit Layouts...
  In the Edit window, you can add a new saved layout and edit the various aspects of the layout.

To add a new layout to the list:
- Click on New Layout
- Select and edit the layouts name
- Press the Enter key.

To edit the configuration of a saved layout:
- Press the Edit Layouts tab
- Choose a configuration, then click-drag on the center bars to edit the layout.

Display options
Using the Shading menu on each view panel, you can choose which kind of display you want for your geometry.

To change your panel display:
- Go to the panel's Shading menu and select one of the options
- Make the panel you wish to change the active panel
- Use one of the following hotkeys to switch display types:
  4 for wireframe;
  5 for smooth shaded.

Texturing and lighting
Another important option found on this menu is hardware texturing. This option allows you to visualize textures interactively in the view panels.

To use hardware texturing:
- Build a shader that uses textures
- Go to the panel's Shading menu and select Hardware Texturing

Or
- Press the following hotkey:
  6 for hardware texturing

To display different textures:
It is possible to display different texture maps on your surface during hardware texturing. For instance, you could display the color map or the bump map.
- Select the material that is assigned to your objects
- In the Attribute editor, open the Hardware Texturing section and set the Textured channel to the desired channel.
- You can also set the Texture quality for each material node.

To add hardware lighting to your scene:
- Add a light into your scene
- Go to the panel's Lighting menu and select one of the options

Or
- Press the following hotkey:
  7 for realistic lighting

To increase objects smoothness:
- Go to the Display menu and under NURBS Smoothness choose one of the options

Or
- Use one of the following hotkeys to switch display types:
  1 for rough;
  2 for medium;
  3 for fine

Or
- Hold the d key, LMB click and choose an option from the marking menu

Surface smoothness

Tip:
If you want to set a particular smoothness when you first place a piece of geometry into the scene, go to the Window → Settings/Preferences → Preferences. In the Display section, you have various options for setting defaults.

Show menu
The Show menu is an important tool found on each view panel's menu. This menu lets you restrict what each panel can show on a panel-by-panel basis.
Restricting what each panel shows, lets you display curves in one window and surfaces in another to help edit construction history. Or you can hide curves when playing back a motion path animation while editing the same curve in another panel.

To go back to a full user interface:
- Go to the Display menu and select UI Elements → Restore UI Elements.

**Menus**
Most of the tools and actions you will use in Maya are found in the main menus. The first six menus are always visible, while the next few menus change depending on which UI mode you are in.

Menus and menu pop-ups that display a dotted line at the top can be ‘torn off’ for easier access.

To tear off a menu:
- Pull down on the menu then release as your mouse hits the top of the menu.

Later in this chapter, you will look at the difference between the two main types of menu items—tools and actions.

**Menu sets**
There are four menu sets in Maya: Animation, Modeling, Dynamics and Rendering. These allow you to focus on tools appropriate to a particular workflow.

To choose a menu set:
- Select the menu set from the pop-up menu found at the left of the Status Line bar.

To choose a menu set using hotkeys:
- Press the h key and choose the desired UI mode from the radial marking menu.

To choose a menu set using function keys:
- Press F2 for Animation;
- Press F3 for Modeling;
- Press F4 for Dynamics;
- Press F5 for Rendering

**Status Line**
The Status Line provides feedback on settings that affect the way the tools behave. The display information consists of:
- the current menu set
- icons that allow you to create a new, open a saved, or save the current
- the selection mode and selectable items
- the snap mode, the history of the selected object (visible by pressing the input and output buttons)
- the construction history flag
- Render into new window and IPR button
- quick selection field

To collapse part of shelf buttons:
- Press the small handle bar next to a the button set.

**The shelf**
Another way of accessing tools and actions is using the shelf. You can move items from the menu to the shelf to begin combining tools into groups based on your personal workflow needs.

To add a menu item to a shelf:
- Press Ctrl+Alt+Shift then select the menu item. It will appear on the active shelf.

To edit the shelf contents and labels:
- Go to the Windows menu and select Settings/Preferences → Shelves...

**Hotbox**
As you have learned, pressing the spacebar quickly pops a pane between full screen and its regular size. If you press a little longer, you gain access to the hotbox.
Lesson 5
Hotbox Marking Menus

The hotbox is a user interface tool that gives you access to as much or as little of the Maya UI as you want. It appears wherever your cursor is located and offers the fastest access to tools and actions.

To access the hotbox:
- Press and hold the spacebar.

Hotbox Controls

The hotbox with four quadrants marked

The hotbox offers a fully customizable interface element that provides you with access to all of the main menus as well as your own set of marking menus.

You can use the Hotbox Controls to display or show as many or as few menus as you need, and you can configure up to 15 different marking menus for fast interaction.

Hotbox Marking Menus

You can access marking menus in five areas of the hotbox. Since each of these areas can have a marking menu for each mouse button, it is possible to have 15 menus in total. You can edit the content of the marking menus by going to the Window menu and selecting Settings/Preferences → Marking Menus.

To access the center marking menu:
- Press the spacebar.
- Click and drag in the center area to access the desired menu.

Center Marking Menu

A complete hotbox layout

To customize the hotbox:
- Use the Hotbox controls
- Use the center marking menu
- Choose an option from the Hotbox Styles menu

Tool Manipulators

To the left of the workspace you have access to important tools. These include the Select, Move, Rotate, Scale, and Show manipulator tools. Each of these is laid out to correspond to a related hotkey that can be easily remembered using the QWERTY keys on your keyboard.

Customizing the Hotbox

You can customize the hotbox to make it as simple or as complex as you need. You can choose which menus are available and which are not.

If you want, you can reduce the hotbox to its essentials and focus on its marking menu capabilities.

A reduced hotbox layout

Alternatively, you could hide the other UI elements, such as panel menus, and use the hotbox for access to everything. You get to choose which method works best for you.
LESSON 5
Transform manipulators

and blue for Z. Selected handles are displayed in yellow.

Scale Rotate Move

To use a transform manipulator in view plane:
- Click-drag on the center of the manipulator

To constrain a manipulator along one axis:
- Click-drag on one of the manipulator handles

Drag on handles to constrain

The QWERTY tool layout
These tools will be used for your most common tool-based actions—like selecting and transforming.

To explore some of the options available with manipulators, you will use the transform manipulator.

Note: The Y key drives the last spot on the QWERTY palette which is for the last tool used. The advantages of this will be discussed later in the Tools and Actions chapter of this document.

Transform manipulators
One of the most basic node types in Maya is the transform node. This node contains attributes focused on the position, orientation and scale of an object. To help you interactively manipulate these nodes, there are three transform manipulators which make it easy to constrain along the main axes.

Each of the manipulators uses a color to indicate their axes. RGB is used to correspond to XYZ. Therefore, red is for X, green for Y

The ability to constrain in two axes at a time is available to only the move manipulator.

Using the mouse buttons
When working with manipulators, you can use the left mouse button to select objects and interact directly with manipulators. The middle mouse button is for the active manipulator and lets you click-drag without direct manipulation.

To select objects:
- Press the Ctrl key and click on the center of the transform manipulator.

To select multiple objects:
- Click-drag in a bounding box around objects.

Or
- Press Shift, and with the left mouse button click on multiple objects

To manipulate objects directly:
- Click-drag on a manipulator handle

To manipulate objects indirectly:
- Click-drag with the middle mouse button

Shift gesture
The manipulators allow you to work effectively in a Perspective view panel when transforming objects.

If you want to work more quickly when changing axes for your manipulators, there are several solutions available:

To change axis focus using hotkeys:
- Press-hold on the transform keys: w for move; e for rotate; r for scale
- Choose an axis handle for constraining from the marking menu

To change axis focus using shift key:
- Press the Shift key
- Click-drag with the middle mouse button in the direction of the desired axis.
Lesson 5
Set pivot

Transform manipulators

Set pivot
The ability to change the pivot location on a transform node is very important for certain types of animation.

To change your pivot point:
- Select one of the manipulator tools
- Press the Insert/Home key
- Click-drag on a manip to move pivot
- Press Insert/Home to return to the manipulator tool

Numeric Input
To add values to your transformations using accurate values, you can use the numeric input box. This allows you to apply exact values to the attributes associated with the current manipulator. You can use the Command Feedback line to check out current values and to confirm your results.

To access the Help Line:
- From the Display menu, select UI Elements → Help Line.

To change focus to the coordinate box:
- Click on the box
Or
- Press the Alt-~ keys

To change all values at once:
- Enter three values in a row, with spaces in between

Note:
Beside the coordinate box is a button to toggle between absolute and relative values. The default is absolute.

To enter a value for the active manipulator:
- Click on the desired handle (e.g., Z-translate)
- Enter a single value.

Note:
If no manipulator handle is active, then the single value will be applied to X.

To enter a value while preserving others:
- Type in periods (,) for channels that you want to stay the same
- Remember to add spaces in between

Enter a numeric value for the channels that will change.
The example below would keep the X and Y values constant and change only the Z information.

Architects 7

Entering periods to keep values constant

Channel box
Another way of entering accurate values is the Channel box. This powerful panel gives you access to an object's transform node and any associated input nodes.

If you have multiple objects selected, then your changes to a channel will affect all the nodes which share that attribute.

To put one of the selected objects at the top of the Channel box so that it is visible, choose the desired node from the channel box's Object menu.

If you want to work with a particular channel, you can use the Channels menu to set keys, add expressions and complete other useful tasks. You can also change the display of the Channel box names to short MEL-based names.

To enter a value for the channels that will change:

The example below would keep the X and Y values constant and change only the Z information.

Architects 7

Entering periods to keep values constant

Channel box and manipulators
One of the features of the Channel box is the way in which you can use it to access manipulators at the transform level.
By default, the Channel box is set to show manipulators each time you tab into a new Channel box field. You will notice that as you select the channel names such as Translate Z or Rotate X, the manipulator switches from translate to rotate.

One fast way of working is to select the name of the desired channel in the Channel box, then use the middle mouse button to edit the value by click-dragging in a view panel.

There are three options for the Channel box manipulator setting:

**Default manipulator setting**
This setting lets you activate the appropriate field in the Channel box, and then modify the values with either the left or the middle mouse buttons.

To use the default method, complete the following steps:

- Click on the desired channel name or within the channel's input field.
- Click-drag directly on the active manipulator with the left mouse button.

Or

- Click-drag in open space with the middle mouse button.

This may be the easier method since you can click remotely.

**No-manipulator setting**

No-visual manipulator setting

A third option found on this manip button returns manipulator capability to the Channel box – but now you won't see the manipulator on the screen, as shown in the icon at the bottom of the Channel box.

- Click on the desired channel name or within the channel's input field.
- Click-drag in open space with the middle mouse button.

You can now use the two new buttons that let you edit the speed and droppoff of the manipulations.

**Attribute Editor**

If the Channel box lets you focus on attributes that are keyable using Set Key, then the Attribute Editor gives you access to all the rest of the attributes/channels.
LESSON 5
Selection masks

The Attribute Editor is used for all nodes in Maya. This means that shaders, textures, surfaces, lattices, render globals, etc. can all be displayed in this one type of window.

To open the Attribute Editor window:
- Select a node.
- Go to the Window menu and select Attribute Editor.

To open the Attribute Editor panel:
- Select a node.
- Go to the Display menu select UI Elements → Attribute Editor. The Channel box is now replaced by an Attribute editor panel.

When you open up the Attribute Editor, you get not only the active node, but also related nodes based on dependency relationships. In the example below, a sphere's transform, shape and makeNurbsSphere nodes are all present. These are the same input and shape nodes shown in the Channel box.

A typical Attribute Editor

SELECTING IN MAYA

One of the most important tasks when working in Maya is your ability to select different types of nodes and their key components.

For instance, you need to be able to select a sphere and move it, or you need to select the sphere's control vertices and move them. You also need to distinguish between different types of objects so that you can select only surfaces or only deformers.

Selection masks

To make selecting work in Maya, you have a series of selection masks available to you. This allows you to have one Select tool that is then masked so that it can only select certain kinds of objects and components. The selection mask concept is very powerful because it allows you to create whatever combination of selecting types that you desire. Sometimes, you only want to select joints and selection handles, or maybe you want to select anything but joints. With selection masks, you get to set up and choose the select options.

The selection user interface

The user interface for selecting offers several types of access to the selection masks. You can learn all of them now and then choose which suits your way of working down the line.

Grouping and parenting

When working with transform nodes, you can build more complex structures by building hierarchies of these node types.

To build these structures, you can choose to group the nodes under a new transform node or you can parent one of the nodes under the other so that the lower node inherits the motion of the top node.

Selection modes

At the top of the workspace, you have several selection mask tools available. These are all organized under three main types of select modes. Each of these gives you access to either the hierarchy, object type or components.

Hierarchy  Object  Component
The select modes

Scene hierarchy mode

Hierarchy mode gives you access to different parts of the scene hierarchy structure. In the example shown below, the leaf node and the root node are highlighted. This mode lets you access each of these parts of the hierarchy. You can select root nodes, leaf nodes and template nodes using the selection masks.

Object mode

Object mode lets you perform selections based on the object type. Selection masks are available as icons which encompass related types of objects.

With your right mouse button, you can access more detailed options that are listed under each mask group. If you create a partial list, the mask icon is highlighted in orange.

Click with RMB on icon for list
Object mode with selection masks

Tip: Once you choose selection masks, Maya gives priority to different object types. For instance, joints are selected before surfaces. You will need to use the Shift key to select these two object types together. To reset the priorities, select Window → Settings/Preferences → Preferences and click on the Selection section to modify the Priority.
LESSON 5
Component mode

A lattice object and a curve object selected

CV components and lattice point components

Tip: To toggle between object and component modes, press the F9 key

RMB select
Another way of accessing the components of an object is to select an object, then press the right mouse button. This brings up a marking menu that lets you choose from the various components available for that object

The right mouse button select menu
If you then select another object, you return to your previous select mask selection. This is a very fast way of selecting components when in hierarchy mode, or for components that are not in the current selection mask

Combined select modes
Just in front of the selection mask mode icons is a pop-up menu that gives you different preset mask options. These presets let you combine different object and component level select options.

An example would be the NURBS option. This allows you to select various NURBS-based mask types such as surfaces, curves, CVs, curve control points and isoparms.

Tip: If a menu item says "Curve tool" then it uses tool interaction. If the word "tool" is not mentioned then the menu item is set as an action

TOOLS AND ACTIONS
In Maya, there are a large number of menu items that let you act on your scenes in a number of ways. These menu items can be broken down into two types of commands: tools and actions, each working in their own particular way. Almost every function in Maya can be set to be a Tool or an Action.

NURBS select options
LESSON 5
Actions

the Help line at the bottom of the workspace can be used to prompt your actions when using the tool.

Earlier you were introduced to the y key on the QWERTY palette. By default, this button is blank because it has been left over to show the last tool used. When you pick a tool from the menus, its icon inserts itself into the QWERTY menu.

To use as a tool:
- Pick a menu item and go to the options
- Under the Edit menu, select As Tool
  By default, you will remain in this tool until you pick the Select tool or another tool. There is also a setting that will remove you from the tool after the first completion.

To return to the last tool used:
- Press the y key

Actions

Actions follow a selection-action paradigm. This means that you have to first pick something and then act on it. In Maya, this allows you to choose an action, return to editing your work, and then refine the results immediately.

Actions require that you have something selected before acting on it. This means that you must find out what is required to complete the action.

To find out selection requirements of an action:
- Move your cursor over the menu item.
- Look at the Help line at the bottom left of your workspace.

The selection requirements are displayed. For instance, a Loft requires curves, isoparms or curves on surfaces while Insert Isoparm requires that isoparms be picked.

To complete the action:
- If the tool is not already set as an action, select Edit → As Action from the menu items’ options.
- Use either pick modes or the right mouse button pick menu to make the required selections.
- Choose the action using either the hotbox, shelf or menus.

The action is complete and your focus returns to your last transform tool.

A typical action: 2D fillet

A good example of a typical action is a 2D fillet. As with all actions, you must start with an understanding of what the tool needs before beginning to execute the action.

1 Draw two curves
   - Select Create → CV Curve Tool
   - Place several points for one curve
   - Press Enter to complete
   - Press the y key to refocus on curve tool.
   - Draw the second curve so that it crosses the first.
   - Press the Enter key to complete

2 Find out 2D fillet requirements
   - In the Modeling menu set, move your cursor over the Edit Curves → Curve Fillet menu item.
   - Look in the Help line to find out what kind of pick is required.
   - The Help line is asking for curve parameter points.

3 Pick the first curve point
   - Click on the first curve with the right mouse button.
   - Pick Curve Point from the selection marking menu.
   - Click on the curve to place the point on the side you want to keep.

4 Pick the second curve point
   - Click on the second curve with the right mouse button.
   - Pick Curve Point from the selection marking menu.
   - Press the Shift key and click on the curve to place the point on the side of the curve you want to keep.
   - The Shift key lets you add a second point to the selection list without losing the first curve point.

Note: You must first use the marking menu then use the Shift key to add a second point to the selection list, otherwise the selection menu will not appear.
LESSON 5
A typical Tool: 2D fillet

5 Fillet the curves
- Select Modeling → Edit Curves → Curve Fillet -1 to open the tool options
- Turn the trim option on
- Click on the Fillet button

Fillet tool options window

Final filleted curves

A typical Tool: 2D fillet
With this example you will use the menu item as a Tool rather than an Action.

1 Draw two curves
- In a new scene, draw two curves as in the last example

Two curves for filleting

2 Change Curve Fillet to Tool
- Select Edit Curves → Curve Fillet -1
- Select Edit → As Tool from the options window
- Set Trim to On

Press the Fillet Tool button

3 Pick the first curve
- Click with the left mouse button on the first curve

First curve selected

4 Pick the second curve
- Click with the left mouse button on the second curve

Final filleted curves

Conclusion
You now know how to navigate the Maya user interface and how the tools and actions work. The skills you have learned here will be applied throughout the rest of this book. It is now up to you to choose how you want to use the interface. Try out the different techniques taught here as you work through the Learning Maya projects.

In the next chapter, you will explore Maya’s Dependency graph. You will learn about the different Maya nodes and how to build them into hierarchies and procedural animations.
In the first four lessons of this book, you were able to interactively animate a ball bouncing. Along the way, you encountered many nodes which helped you build up and animate the scene. You came across input nodes, hierarchy nodes, shading group nodes and texture nodes, as well as emitter and particle nodes. These nodes represent key elements within Maya - each node containing important attributes which help you define and animate your scenes.

Maya’s architecture is defined by this node-based system that is known as the Dependency graph. Each of your nodes contains attributes which can be connected to other nodes. If you wanted to reduce Maya to its bare essentials, you could basically describe it as nodes with attributes that are connected. This node-based approach gives Maya its open and flexible procedural characteristics.

In this chapter, you are going to explore nodes, attributes and connections by animated objects at various levels. You will explore how attributes are connected by Maya and how you can connect them yourself. You will also learn how to distinguish scene hierarchies from object dependencies.

This chapter will at first seem a bit abstract, but in the end you will be able to see how the various nodes contribute to an animated scene which will help you in later lessons.
Hierarchies and dependencies

3 View the shape node

In the Hypergraph panel, you are currently looking at the scene view. The scene view is focused on transform nodes. This type of node lets you set the position and orientation of your objects.

Right now, only a lone nurbsSphere node is visible. In actual fact, there are two nodes in this hierarchy but the second is hidden by default. At the bottom of most hierarchies, you will find a shape node which contains the information about the object itself.

- In the Hypergraph, select Options → Display → Shape nodes.

You can now see the transform node which is in effect the positioning node, and the shape node which contains information about the actual surface of the sphere. The transform node defines the position of the transform node on its own.

New sphere

4 View the dependencies

To view the dependencies that exist with a primitive sphere, you need to take a look at the up and downstream connections.

- In the Hypergraph panel, click on the Input and Output Connections button.

The original transform node is now separated from the shape node.

When collapsed, the transform node takes on the shape node’s icon to help you understand what is going on underneath.

When collapsed, the transform node takes on the shape node’s icon to help you understand what is going on underneath.

You will also see the initial Shading group connected to the sphere. This is the default gray Lambert that is applied to all new objects.

5 Edit attributes in the Channel box

In the Channel box, you can edit attributes belonging to the various nodes. All of the node types can be found in the Channel box. This lets you affect both hierarchical relationships and dependencies.

If you edit an attribute belonging to the makeNurbsSphere node, then the shape of the sphere will be affected. If you change an attribute belonging to the nurbsSphere transform node, then the positioning will be changed. Use the Channel box to help you work with the nodes.

- For the transform node, change the Rotate Y value to 45.

- For the makeNurbsSphere input node, change the Radius to 3.

You can set attribute values to affect either the scene hierarchy or the Dependency graph.
Shading group nodes

In earlier lessons, the word *node* was used a great deal when working with shading groups. In fact, shading group nodes create dependency networks which work the same way as shape nodes.

1. **Create a shading group**

   When you create a shading group you are creating two main nodes that are connected – the shading group node and the material node.
   - Select Window → Rendering Editors → Hypershade
   - In the Hypershade window, select Create → Materials → Phong. Assign this material to the sphere.
   - Select the sphere in the perspective panel then click on the Input and Output Connections button.

   In the Hypergraph view, you will notice how the input node is connected to the shape node which relates to the phong shading group.

   A line is now drawn between the shape’s shape node and shading group node. This is because the shading group is dependent on the surface in order to render.

   Every time you assign a shading group to an object you make a dependency graph connection.

2. **Open the Attribute Editor**

   You have seen how the nodes in the Hypergraph and the Channel box have been used to view and edit attributes on connected nodes. Now you will see how the Attribute Editor displays nodes, attributes and connections.

   - Click on the Scene Hierarchy button in the Hypergraph Panel to go back to a scene view.
   - Select the sphere’s transform node.
   - Press Ctrl-e to open the Attribute Editor.

   In this important window, you will see several tabs each containing groups of attributes. Each tab represents a different node. All the tabs displayed represent parts of the selected node’s Dependency graph that are related to the chosen node. By bringing up several connected nodes, you have easier access to particular parts of the graph.

   - Select the Input and Output Connections button

   Related Nodes

   - Related Nodes

   Nodes and attributes in Attribute Editor

   - Close this window.

**Note:** In Maya, the Dependency graph lets you focus on one part of the graph at a time.

**Making your own connections**

To help you understand exactly what a Dependency graph connection is, you are going to make your own connection and see how it affects the graph.

1. **Open the Connection Editor**

   - Select Window → General Editors → Connection Editor.
   - Click on the Reload Left button.

   The selected transform node is loaded into the left column. All of the attributes belonging to this node are listed.

   - Select the Transform node from the left column.

   Related Nodes

   - Related Nodes

   Nodes and attributes in Attribute Editor

   - Close this window.

**Note:** There are more nodes here than you saw earlier in the Channel box. The Channel box only shows attributes that have been set as keyable. Other nodes can be found in the Attribute Editor.
Lesson 6
Making your own connections

1. In the left hand column, scroll down until you find the Translate attributes.
2. Click on the plus sign to open this attribute type and see the Translate X, Y and Z attributes. Be sure not to click on the name.
3. In the right hand column, scroll down until you find the Color attribute.
4. Click on the plus sign to open this attribute type and see the Color R, G and B attributes.
5. Click on the Translate X attribute in the left hand column.
6. Click on the Color R in the right hand column.

Transform node in Connection Editor

2 Add phong as the output node

- In the Hypergraph, select Rendering -> Show Materials.
- Select the phong1 material node.
- In the Connection Editor, click on the Reload Right button.

Material node in Connection Editor

3 Make node connections

You will now connect some attributes in from the transform node to the material node.

4 View the connections

- In the Hypergraph panel, select the phong node then click on the Input and Output Connections button.
- Move your cursor over one of the arrow connections between the transform node and the material node.

5 Move the sphere

- In the Perspective view, select the sphere.
- Move the sphere along the X-axis. The color of the sphere changes to red. By increasing the value of the translation along X, you add red to the color.
- Try moving the sphere along each of the three main axes to see the colors change.

Adding a texture node

While it is a fun and educational exercise to see the material node's color dependent on the position of the ball, it may not be very realistic. You will now break the existing connections and map a texture node in their place.

Deleting connections

You can delete the connections in the Hypergraph view.

- In the Hypergraph view panel, select one of the three connection arrows between the transform node and the material node.
- Press the Backspace key to delete the connection.
- Repeat for the other two connections between these nodes.

Viewing attribute connections

Broken connections

2 Add a checker texture map

You will now use the Attribute Editor to help you add a texture to the existing shading group.

- Click on the phong1 material node.
- Press Ctrl to open the Attribute Editor.
- Click on the Map button next to Color.
- Choose a Checker texture from the Create Render node window.
- Move your cursor over the Perspective view panel and press 6.
The key and tangent information is placed in a separate animation curve node that is then connected to the animated attribute.

1. **Select the sphere**
   - In the Hypergraph panel, click on the **Scene Hierarchy** button.
   - Select the *nurbsSphere* transform node.

2. **Return the sphere to the origin**
   Since you earlier moved the sphere along the three axes, it's a good time to set it back to the origin.
   - In the Channel box, set the Translate X, Y and Z to 0, 0, 0.
   - In the Channel box, change the Rotate Y attribute to 0.

3. **Animate the sphere's rotation**
   - In the Time slider, set the playback range to 120 frames.
   - In the Time slider, go to frame 1.
   - Click on the Rotate Y channel name in the Channel box.
   - Click with your right mouse button and select **Key Selected** from the pop-up menu.
   - This sets a key at the chosen time.
   - In the Time slider, go to frame 120.
   - In the Channel box, change the Rotate Y attribute to 720.
   - Click with your right mouse button and select **Key selected** from the pop-up menu.
   - Playback the results.
   The sphere is now spinning.

4. **View the dependencies**
   - In the Hypergraph panel, click on the Input and Output Connections button.
   
   You see that an animation curve node has been created and then connected to the transform node. The transform node is now shown as a trapezoid to indicate that it is now connected to the animation curve node. If you click on the connection arrow, you will see that the connection is to **Rotate Y**.
   
   If you select the animation curve node and open the Attribute Editor, you will see that each key has been recorded along with value, time and tangent information. You can actually edit this information here, or use the Graph Editor where you get more visual feedback.

You will build a hierarchy of spheres that are rotating like planets around the sun. This example is a helpful way to understand how scene hierarchies work.

1. **Create a new sphere**
   - Go to frame 1.
   - In the Hypergraph panel, click on the **Scene Hierarchy** button.
   - Select Create → NURBS Primitives → Sphere.
   - Move the sphere along the Z axis until it sits in front of the first sphere.
   - Press 3 to increase the display smoothness of the sphere.
   - Go to the **Rendering** menu set.
   - Select Lighting/ Shading → Assign Existing Material → phong.

2. **Parent the sphere**
   - Press the Shift key and select the first sphere.
   - Press the p key to parent the new sphere to the first.
   - The p key does the same thing as selecting Edit → Parent.
LESSON 6
Building scene hierarchies

- Play back the scene.
  The second sphere rotates along with the first sphere. It has inherited the motion of the original sphere.

Note: One way of thinking of the hierarchy is to think of a person walking on our own planet. As the planet revolves around its axis, the person revolves too. The person can also walk, jump, or spin.

4 Create another sphere
To make this point more clear, you will add a third sphere to the hierarchy to see what happens:
- Go to frame 1
- Select Create → NURBS Primitives → Sphere
- Move the sphere along the Z-axis until it sits in front of the second sphere.
- Scale the sphere in all three axes to about one third its size.
- Press 3 to increase the display smoothness of the sphere.
- Go to the Rendering menu set.
- Select Lighting/Shading → Assign Existing Material → phong1

3 Animate the new sphere's rotation
While child nodes in a hierarchy inherit the motion of the parent, they can also contain their own animation.
- Go to frame 1
- With the new sphere selected, go to the Channel box and select Key Selected for the Rotate Y channel.
- Go to frame 120
- In the Channel box, change the Rotate Y attribute to -1440
- Key Selected for the Rotate Y channel.
- Playback the scene.
  The second sphere rotates in the opposite direction as it revolves around the first sphere.

5 Parent the sphere
- In the Hypergraph panel, click on the scene hierarchy button.
- Now use the middle mouse button to click-drag the new transformer node onto the second sphere’s transform node. This is another method for parenting nodes.
- Play back the scene.
  The third sphere revolves with the rotation of the second sphere. This hierarchy is then revolved around the first sphere.

The hierarchy is now rotating at an angle. You have changed the axis of the whole system.

Repositioned hierarchy

Understanding how hierarchies work will be an important part of working with Maya. In upcoming lessons, keep an eye on how hierarchies are built, especially when you begin building characters.

Hiding objects
Before moving onto a more complex animation, you will hide the existing hierarchy. This will let you focus on the second part of this lesson.

1 Hide the grouped hierarchy
- With the new group selected, select Display → Hide → Hide Selection.

Invisibility node

Third sphere scaled down

Scene hierarchy view
**Procedural animation**

If Maya's procedural nature is defined as nodes with attributes that are connected, then a procedural animation would be set up by animating attributes at various levels of a Dependency graph network.

You will now build a series of animated events that build on each other to create the final result.

1. **Create an edit point curve**
   - Select **Create → EP Curve Tool**.
   - Press the 'x' key to turn on grid snap.
   - Draw a curve as shown below.
   - When you are finished, press Enter then select **Modify → Center Pivot**.

2. **Duplicate the curve**
   - Select **Edit → Duplicate**
   - Move the new curve to the opposite end of the grid.

3. **Create a lofted surface**
   - A lofted surface can be created using two or more profile curves.
     - Click-drag a selection box around both of the curves.
     - Select **Surfaces → Loft**.
     - Press 3 to increase the surface display smoothness.

4. **Change your panel display**
   - In the Hypergraph panel, select **Panels → Perspective → persp**.
   - In the Perspective panel, select **Show → None then Show → NURBS Curves**.

Now you have two Perspective views. One shows the surface in shaded mode and the second shows only the curves. This makes it easier to pick and edit the curves in isolation from the surface itself.

5. **Edit CVs on the original curves**
   - Select the first curve.
   - Click with your right mouse button to bring up the selection marking menu and select **Control Vertex**.
   - Click-drag a pick box over one of the CVs and **Move** it down.

**Note:** The dependencies associated with models are sometimes referred to as construction history. By updating the input shape, you have in effect updated the history of the lofted surface.

---

**Creating a curve on surface**

You will now build a curve directly onto the surface. This curve will become dependent on the shape of the surface for its own shape.

The surface was built as a grid of surface lines called *nurbs*. These lines help define a separate coordinate system specific to each surface. Whereas world space coordinates are defined by X, Y, and Z, surface coordinates are defined by U and V.

1. **Make the surface live**
   - So far, you have drawn curves into the world space coordinate system. You can also make any surface in Maya into a live surface and draw into the UV space of the surface.
     - Select the lofted surface.
     - The CVs on the curve disappear and you are able to focus on the surface.
LESSON 6
Create group hierarchy

- Select Modify → Make Live
- Select Display → Grid to turn off the ground grid

2 Draw a curve on the surface
- Select Create → EP Curve Tool
- Draw a curve on the live surface

Moving the curve on surface

Tip: This UV space is the same used by texture maps when using 2D placement nodes

3 Move the curve on surface
- Press the Enter key to complete the curve
- Select the Move tool

The move manipulator looks a little different this time. Rather than three manipulator handles, these are only two. One is for the U direction of the surface and the other is for the V direction.
- Click-drag on the manipulator handles to move the curve around the surface space

4 Make the ground grid live
- Click in empty space to deselect the curve on surface
- Select Modify → Make Not Live

With nothing selected, the ground grid becomes the active or live grid

Create group hierarchy
You are now going to build another hierarchy. This time you will group two primitives, then animate the group along the curve on surface using path animation

1 Create a primitive cone
- Select Create → NURBS Primitives → Cone
- Press the 3 key to increase its display smoothness

2 Create a primitive sphere
- Select Create → NURBS Primitives → Sphere
- Press the 3 key to increase its display smoothness
- Move the sphere above the cone

3 Group the two objects
- Select the cone and the sphere
- Select Edit → Group
- Select Display → Component Display → Selection Handles

The selection handle is a special marker that will make it easier to pick the group in object selection mode

THE DEPENDENCY GRAPH
Create a path animation

To animate the new group, you will attach it to the curve on surface. You can use the curve on surface to define the group’s position over time.

1 Attach to the curve on surface
- With the group still selected, press the Shift key and select the curve on surface
- Go to the Animation menu set
- Select Animate → Motion Paths → Attach to Motion Path → On. In the option window, make sure that the Follow option is turned Off.
- Click Attach
- Play back the results

As the group moves along the path curve, you will notice that it is always standing straight up
2 Constrain to the surface normal
You will now constrain the orientation of the group to the normal direction of the lofted surface. The normal is like the third dimension of the surface’s UV space:

- Click in open space to deselect the active objects
- Select the loft surface
- Press the Shift key and select the grouped primitives using the selection handle
- Select Constrain → Normal - In the option window, set the following:
  - Aim Vector to 0, 1, 0:
  - Up Vector to 1, 0, 0
- Click Add/Remove then Close
- Play back the results

Now the group is orienting itself based on the normal direction of the surface. The group is now dependent on the surface in two ways: Firstly, its position is dependent on the path curve, which is dependent on the surface for its shape. Secondly, its orientation is directly dependent on the surface’s shape.

Layer the animation
In Maya, the various parts of the Dependency graph can all be animated to create exciting results. To see the Dependency graph in motion, you will animate different nodes within the network to see how the dependencies react.

1 Edit the loft curve shape
Since the shape of the surface is dependent on the original loft curves, you will start by animating the shape of the second curve:

- Select the second loft curve. You may want to use the second Perspective panel which is only displaying curves
- Click with your right mouse button to bring up the selection marking menu and select Control Vertex

Control vertices help define the shape of the curve. By editing these, you are editing the curve’s shape node.
- Click-drag a pick box over one of the CVs and Move it up to a new position

As you move the CV, the surface updates its shape, which in turn redefines the curve on surface and the orientation of the group. All the dependencies are being updated.

3 Animate the curve on surface
To add another layer of animation, you will key the position of the curve on surface.

- Select the curve on surface
- Go to frame 1 in the Time slider
- Press s to set key
- Go to frame 120 in the Time slider
- Press s to set key
- Move the CV down to a new position
- Press s to set key
- Play back the results

You can see how the dependency updates are maintained as the CV is animated. You are animating the construction history of the lofted surface and the connected path animation.
Lesson 6
Layer the animation

4 Assign the phong shading group

To make it easier to see the animating objects, apply the checker shading group to the primitive group. You will also make visible the animated hierarchy to see all the pieces together.
- Select the primitive group using its selection handle
- Go to the Rendering menu set
- Select Lighting/Shading → Assign Existing Material → phong
- Select Display → Show → Show Last Hidden
- Play back the scene

5 Connect two of the spheres

To add your own connection into the equation, you will now connect the rotation of the large sphere from the original hierarchy with the sphere that sits on the cone.
- Select Window → General Editors → Connection Editor
- Select the large sphere from the original hierarchy
- In the Connection Editor, click on the Rotate Left button
- Select the sphere that is sitting on top of the cone without using the selection handle
- In the Connection Editor, click on the Reload Right button
- In the left hand column, scroll down to the Rotate section
- Click on the plus sign next to Rotate to open this section then click on Rotate Y

- Repeat these steps for the right hand column. When you click on the Rotate Y attribute for the second sphere, the two are connected

Select the primitive group that is attached to the motion path
- Open the Hypergraph panel and click on the Input and Output Connections button

The resulting network contains the various dependencies that you built during this example.

Curve on surface

Normal Constraint

The dependency network

Conclusion

Maya’s procedural qualities are tied to how the Dependency graph uses nodes, attributes and connectors. You can see how deep these connections can go and how they are maintained throughout the animation process. Similar techniques can be used on other node types throughout Maya.

Obviously, you don’t have to use the Hypergraph and the Connection Editor to build, animate and texture map your objects. But in most cases, you will be thinking more about the motion of your character’s walk or the color of their cheeks. In this way, it is a good idea to know that the Dependency graph underlies everything that you do and can always be used to your advantage.