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About myself 
 
My name is Jan-Willem Zuyderduyn and I am the founder  
and owner of LearnSolidWorks.com.  
 
I’ve been working over twelve years with 3d CAD software 
and over eight years with SolidWorks. In that time I’ve 
learnt a lot about all the possibilities with SolidWorks.   
 
I am graduated in 2008 with a Bachelor Degree in Product 
Design & Engineering. I’ve worked for Sinot Yacht Design 
as yacht designer. I am currently working as an Industrial 
Designer for the TSG Group in Eindhoven, the design city 
of the Netherlands.  I am also working as freelance 
designer and SolidWorks teacher of ”Advanced Surface 
Modeling 3”. I am specialized in concept design, 3d 
modeling and visualizations. If you need a freelance 
designer for a project, don’t hesitate to send an e-mail to 
info@learnsolidworks.com  
 
In 2007 and 2008 I ended in the top 3 of the international 
SolidWorks Car Design Contest of the Benelux (2007) and 
Europe (2008). It took me six years to learn everything 
about SolidWorks what I know now. In that time I have been asked many times how to 
model and render 3D models using SolidWorks. The last few years I’ve written multiple e-
books and tutorials about SolidWorks. My mission is to assist as many people as I can with 
learning SolidWorks. That’s why I’ve created this website, LearnSolidWorks.com. By the way, 
I am not related or affiliated with SolidWorks in any way. 
 
I hope you will learn something from this tutorial. Feel free to leave a Comment on the 
LearnSolidWorks website or to Share it with your friends. This free SolidWorks tutorial is a 
complimentary resource. You may distribute (I encourage you to share) this tutorial as a free 
gift, or post it on your website as long as the content is not changed and it is delivered via 
this PDF file. It’s not allowed to sell this E-book because I offer it for free on my website. I 
assume no responsibility or liability whatsoever on this materials. 
 
Check the www.LearnSolidWorks.com website for more free SolidWorks tutorials like this 
one. 
 
Enjoy this SolidWorks tutorial! 
 
 
Jan-Willem Zuyderduyn 
 
P.S. Add me on Twitter, and stay up to date with all my newest SolidWorks tutorials: 
http://twitter.com/LearnSW 

http://www.sinot.com/
http://www.totalsupport.com/
mailto:info@learnsolidworks.com
http://learnsolidworks.com/solidworks_tutorials/how-to-model-a-panton-chair-in-solidworks
http://learnsolidworks.com/solidworks_tutorials/how-to-model-a-panton-chair-in-solidworks
http://www.learnsolidworks.com/
http://twitter.com/LearnSW
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How to Model a Deodorant Roller in SolidWorks? 
 

In this tutorial you will learn how to model a Deodorant Roller in SolidWorks. In this lesson 

I’ll show you the following features: 

 Draw a 2d sketch 

 Insert a blueprint 

 Surface Revolve 

 Surface Sweep 

 Surface Loft 

 Surface Fill 

 Surface Knit 

 Fillet 

 New Axis 

 Revolved Cut 
 
Render of the model you will create (made in PhotoView360) 
 
 

 

http://learnsolidworks.com/wp-content/uploads/LearnSolidWorks_Deoroller_001.jpg
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 Open a new part with model units set to millimeters 

Go to: File > New > Part 

 

 
  

  

Create a 2D sketch 
 

Select the Right Plane in the feature tree (menu at the left side) and create a sketch by 

clicking on the 2D Sketch icon  

The display changes so the Right plane faces you. 

 
  

http://learnsolidworks.com/wp-content/uploads/New_Part1.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_001.png
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Insert a reference picture 
 

For this tutorial we use a blueprint of the Deoroller to approach the organic shape as good 

as possible. 

Download the picture here and save it into your SolidWorks folder 

Go to: Tools > Sketch Tools > Sketch Picture  

Go to your SolidWorks folder and select the picture “SIDEVIEW_DEOROLLER.Jpg” 

Click: Open 

Change the dimensions and position of the picture with the menu as shown in the picture. 

Select ‘’Full image’’ in the Transparency tab and change the transparency into 0.40 

Click OK  

Click at the Sketch button in the upper right corner close the 2D Sketch  

 

http://www.learnsolidworks.com/downloads/SIDEVIEW_DEOROLLER.JPG
http://learnsolidworks.com/wp-content/uploads/Sketch_Picture.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/close_sketch.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_002.png
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Insert a second reference picture 
 

Select the Front Plane in the feature tree (menu at the left side) and create a sketch by 

clicking on the 2D Sketch icon  

Download the picture here and save it into your SolidWorks folder 

Go to: Tools > Sketch Tools > Sketch Picture  

Go to your SolidWorks folder and select the picture “FRONTVIEW_DEOROLLER.Jpg” 

Click: Open 

Change the dimensions and position of the picture with the menu as shown in the picture. 

Select ‘’Full image’’ in the Transparency tab and change the transparency into 0.40 

Click OK  

 

http://www.learnsolidworks.com/downloads/FRONTVIEW_DEOROLLER.JPG
http://learnsolidworks.com/wp-content/uploads/Sketch_Picture.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_003.png
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Click at the Sketch button in the upper right corner close the 2D Sketch  

 
  

http://learnsolidworks.com/wp-content/uploads/close_sketch.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_004.png
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Create a 2D sketch 

Select the Right Plane in the feature tree and create a sketch by clicking on the 2D Sketch 

icon  

Draw the two centerlines as shown in the picture  
 

Change the dimensions by clicking at the dimension button  
 

Fix the two lines with the Fix icon  
 

 
  

http://learnsolidworks.com/wp-content/uploads/centerline.png
http://learnsolidworks.com/wp-content/uploads/dimension.png
http://learnsolidworks.com/wp-content/uploads/fix.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_005.png
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Draw the two lines as shown in the picture  
 

Change the dimensions by clicking at the dimension button  

 
  

http://learnsolidworks.com/wp-content/uploads/line1.png
http://learnsolidworks.com/wp-content/uploads/dimension.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_006.png
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Draw a spline without any midpoints  
 

 
  

http://learnsolidworks.com/wp-content/uploads/Spline.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_007.png
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Select one of the straight lines, hold down the control key and select the spline 

Click at the Tangent icon as shown in the picture  
 

Repeat this action for the other side of the spline 

 
  

http://learnsolidworks.com/wp-content/uploads/tangent.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_008.png
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Change the length of the arrows to approach the curve of the blueprint 

 

Click at the Sketch button in the upper right corner close the 2D Sketch  
  

http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_009.png
http://learnsolidworks.com/wp-content/uploads/close_sketch.png
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Create a Surface Revolve 
 

Go to Insert > Surface > Revolve or click at the Revolve icon  
 

Click at the blue Centerline to define the Axis of Revolution  
 

Use the One-Direction option  
 

Set the Revolution Angle to 360 degrees  
 

Click OK  

 

http://learnsolidworks.com/wp-content/uploads/revolve_surface.png
http://learnsolidworks.com/wp-content/uploads/axis_of_revolution.png
http://learnsolidworks.com/wp-content/uploads/one_direction.png
http://learnsolidworks.com/wp-content/uploads/angle.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_010.png
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Create a 2D sketch 
 

Select the Right Plane in the feature tree and create a sketch by clicking on the 2D Sketch 

icon  

Draw the line as shown in the picture  

Change the dimensions by clicking at the dimension button  

Make sure that the angle of the line is equal to the front curve of the deoroller 

Click at the Sketch button in the upper right corner close the 2D Sketch  

Rename the Sketch4 
 

Double click at Sketch4 in the feature tree and rename it to GUIDELINE_FRONT 

 
  

http://learnsolidworks.com/wp-content/uploads/line1.png
http://learnsolidworks.com/wp-content/uploads/dimension.png
http://learnsolidworks.com/wp-content/uploads/close_sketch.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_011.png
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Create another 2D sketch 
 

Select the Right Plane in the feature tree and create a sketch by clicking on the 2D Sketch 

icon  

Draw the line as shown in the picture  

Change the dimensions by clicking at the dimension button  

Make sure that the angle of the line is equal to the back curve of the deoroller 

Click at the Sketch button in the upper right corner close the 2D Sketch  

Rename the Sketch5 
 

Double click at Sketch5 in the feature tree and rename it to GUIDELINE_BACK 

 

 
  

http://learnsolidworks.com/wp-content/uploads/line1.png
http://learnsolidworks.com/wp-content/uploads/dimension.png
http://learnsolidworks.com/wp-content/uploads/close_sketch.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_012.png
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Create a 2D sketch 
 

Select the Front Plane in the feature tree and create a sketch by clicking on the 2D Sketch 

icon  

Draw a spline without midpoints as shown in the picture  

Change the length of the lower arrow to approach the curve of the blueprint 

Click at the Sketch button in the upper right corner close the 2D Sketch  
 

Rename the Sketch6 
 

Double click at Sketch6 in the feature tree and rename it to GUIDELINE_SIDE 

 

http://learnsolidworks.com/wp-content/uploads/Spline.png
http://learnsolidworks.com/wp-content/uploads/close_sketch.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_013.png
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Create a 2D sketch 
 

Select the Top Plane in the feature tree and create a sketch by clicking on the 2D Sketch 

icon  

Draw the centerline as shown in the picture  

Connect the centerline with the endpoints of GUIDELINE_FRONT and GUIDELINE_BACK 
 

 
 
  

http://learnsolidworks.com/wp-content/uploads/centerline.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_014.png
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Draw a spline with four points as shown in the picture  
 

Connect three points with GUIDLINE_FRONT, GUIDELINE_BACK and GUIDELINE_SIDE 
 

Draw the fourth point somewhere in the space as shown in the picture 

 
  

http://learnsolidworks.com/wp-content/uploads/Spline.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_015.png
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Make the Spline symmetric 
 

Select the right point, hold down the Control key, select the centerline and select the left 

point. 

Click at the Symmetric option in the menu  

Click OK  
 

 
 

Click at the Sketch button in the upper right corner close the 2D Sketch  
 

Rename the Sketch7 

Double click at Sketch7 in the feature tree and rename it to PROFILE 
 
  

http://learnsolidworks.com/wp-content/uploads/Symmetric.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_016.png
http://learnsolidworks.com/wp-content/uploads/close_sketch.png
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Create a 2D sketch 

Select the Right Plane in the feature tree and create a sketch by clicking on the 2D Sketch 

icon  

Draw a line, starting at Origin  

Change the length of the line to 58 mm  

Click at the Sketch button in the upper right corner close the 2D Sketch  
 

Rename the Sketch8 

Double click at Sketch8 in the feature tree and rename it to PATH 

 
  

http://learnsolidworks.com/wp-content/uploads/Origin.png
http://learnsolidworks.com/wp-content/uploads/line1.png
http://learnsolidworks.com/wp-content/uploads/close_sketch.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_017.png


 

©2013 Jan-Willem Zuyderduyn                          LearnSolidWorks.com                        22 | P a g e  
 

Create a Surface Sweep  
 

Go to Insert > Surface > Sweep or click at the Sweep icon  
 

Select the PROFILE sketch in the Feature Tree as Sweep Profile 
 

Select the PATH sketch in the Feature Tree as Sweep Path 
 

 
 

Select GUIDLINE_FRONT, GUIDELINE_BACK and GUIDELINE_SIDE in the Feature Tree as 

Sweep Guides 
 

Click OK  

http://learnsolidworks.com/wp-content/uploads/sweep_surface.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_018.png
http://learnsolidworks.com/wp-content/uploads/ok.png
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http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_019.png
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Create a 2D sketch 
 

Select the Right Plane in the feature tree and create a sketch by clicking on the 2D Sketch 

icon  

Draw the line as shown in the picture  
 

Change the dimensions by clicking at the dimension button  
 

Click at the Sketch button in the upper right corner close the 2D Sketch  

 
  

http://learnsolidworks.com/wp-content/uploads/line1.png
http://learnsolidworks.com/wp-content/uploads/dimension.png
http://learnsolidworks.com/wp-content/uploads/close_sketch.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_020.png
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Trim the upper side of the Surface Sweep 
 

Go to: Insert > Surface > Trim or click at the Trim icon  
 

Click in the Trim tool box  
 

Select the line of the new Sketch9 as shown in the picture. 

Select the “Remove selections” option. 
 

Select the purple surface above the line as shown in the picture.  
 

Surface Split Options: Natural 

Click OK  

 

http://learnsolidworks.com/wp-content/uploads/surface_trim.jpg
http://learnsolidworks.com/wp-content/uploads/trim_tool_box.png
http://learnsolidworks.com/wp-content/uploads/trim_selection.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_021.png
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Create a Surface Loft  
 

Go to Insert > Surface > Loft or click at the Surface icon  
 

Click in the Profiles box  
 

Select the two edges as shown in the picture 

Make sure that the green balls are both on the same end as shown in the picture 

If not, click and drag them to the other side of the sketch 

 
  

http://learnsolidworks.com/wp-content/uploads/Surface_Loft.png
http://learnsolidworks.com/wp-content/uploads/Profiles.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_022.png
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Make the Loft Curvature 
 

Click at the Start/End Contraints box 
 

Set the Start constraint to Curvature To Face as shown in the picture 
 

Set the End constraint to Curvature To Face as shown in the picture 
 

You can optimize the shape of the Loft by changing the Length of the Curvature arrows 

Click OK  

 
  

http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_023.png
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Fill the bottom of the Deoroller 
 

Go to: Insert > Surface > Fill or click at the Fill icon  

 
 

Click OK  

 
  

http://learnsolidworks.com/wp-content/uploads/Fill_Surface.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_024.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_025.png
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Knit the surfaces and create a solid body 
 

Go to Insert > Surface > Knit or click at the Surface Knit icon  
 

Click in the Selections box and select the 4 blue surfaces  
 

Select the ‘’Try to form solid’’ option 
 

Select the “Merge entities” option 
 

Deselect the ‘’Gap Control’’ option 
 

Click OK  

 

http://learnsolidworks.com/wp-content/uploads/Surface_Knit.png
http://learnsolidworks.com/wp-content/uploads/Knit_Selections.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_026.png
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Create a fillet on the edge of the bottom 
 

Go to: Insert > Features > Fillet/Round or click at the Fillet icon  
 

Select the edge as shown in the picture. 

Change the Radius into 2 mm  
 

Click OK  

 
 
  

http://learnsolidworks.com/wp-content/uploads/Fillet_Round.png
http://learnsolidworks.com/wp-content/uploads/Radius.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_027.png
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Create a new Axis 
 

Go to: Insert > Reference Geometry 
 

Select the Cylindrical/Conical Face option 
 

Select the blue surface as shown in the picture 

Click OK  

 
  

http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_028.png
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Create a 2D sketch 
 

Select the Right Plane in the feature tree and create a sketch by clicking on the 2D Sketch 

icon  

Draw the rectangle using the 3 Point Corner Rectangle option as shown in the picture and 

detail  
 

Change the dimensions by clicking at the dimension button  

 
  

http://learnsolidworks.com/wp-content/uploads/3_Point_Corner_Rectangle.png
http://learnsolidworks.com/wp-content/uploads/dimension.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_029.png
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Create a Revolved Cut 
 

Go to: Insert > Cut > Revolve or click at the Cut Revolve icon  
 

Axis of revolution : Select Axis1. 
 

Click OK  

 

Save  the file with the following name: Deoroller.SLDPRT 
  

http://learnsolidworks.com/wp-content/uploads/cut_revolve.png
http://learnsolidworks.com/wp-content/uploads/Axis_of_Revolution.png
http://learnsolidworks.com/wp-content/uploads/ok.png
http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_030.png
http://learnsolidworks.com/wp-content/uploads/save.jpg
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Congratulations, you just finished the Deodorant roller! 
 
 
 
 
 

 

 
 
 
 
 

Did you like this Ebook? Don’t hesitate to send it to your friends! 

http://learnsolidworks.com/wp-content/uploads/Deodorant_Roller_Tutorial_031.png
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Renders made in PhotoView360 

 

http://learnsolidworks.com/wp-content/uploads/LearnSolidWorks_Deoroller_003.jpg
http://learnsolidworks.com/wp-content/uploads/LearnSolidWorks_Deoroller_004.jpg
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What’s next?  

Now that you have made the Double Walled Glass  in SolidWorks you can immediately start 

designing your own products in SolidWorks. With a little bit luck you can create your first 

SolidWorks design in a few days...  

 

I know from experience that it’s hard to start without any basic knowledge of 

SolidWorks. It’s not difficult but you have to know all the possibilities and different features 

of SolidWorks and sometimes it’s difficult to keep up the motivation.  

New Way To Learn SolidWorks   

 
You can now choose to slow down and gently begin to start with SolidWorks but your 
changes to become a great SolidWorks designer are negligible.  
 

You Should Immediately Go For It! 
 
I can imagine that you're thinking: what a lot of work ... sigh And that’s it. You will have to 
work very hard to learn all the different features of SolidWorks. The most people learn all 
the features separately and will later try to bring it all together in one product. Usually this 
learning process takes several years…  
 

Until Now! 
 

Especially for people like you, I have developed the SolidWorks Chopper Tutorial. In this 
Step-by-Step SolidWorks course I will teach you how to Model, Assemble and Render a 
complete Chopper in SolidWorks. Click at the green button below or visit 
http://www.SolidWorksChopper.com 
  
Interested? 
 
 
 
 
 
 
 

 

http://www.solidworkschopper.com/
http://solidworkschopper.com

