Contents

1 Document Overview ........................................... 1-1

2 Barrel Allocator Capabilities .................................. 2-1
   2.1 Generation of Airlift Mission Schedules ..................... 2-1
   2.2 Generation and Assignment of Tanker Missions ............... 2-2
   2.3 Visualization and Analysis of Assignments ................. 2-2
       2.3.1 Mission Window ..................................... 2-3
       2.3.2 Capacity Window ..................................... 2-3
       2.3.3 Map Window .......................................... 2-4
   2.4 Interactive Relaxation of Constraints and Revision of Schedules ..... 2-4
   2.5 Interactive Mission Merging .................................. 2-5
   2.6 Modification of Allocation Parameters ....................... 2-5

3 Barrel Allocator Displays and Menu Commands .................. 3-1
   3.1 AMC Menu Display ....................................... 3-1
   3.2 Mission Window Display ................................... 3-4
       3.2.1 Comparison Sheet ................................... 3-12
   3.3 Capacity Window Display ................................... 3-14
   3.4 Map Window Display ....................................... 3-18
   3.5 Supporting Displays ....................................... 3-22
       3.5.1 Mission Window Gantt Table Column Editor .............. 3-22
       3.5.2 Allocation Preferences Menu .......................... 3-23
       3.5.3 Resource Inspector ................................. 3-24
List of Figures

1. AMC-Menu Display ........................................... 3-1
2. Mission Window Display ................................... 3-4
3. Mission Window Comparison Sheet ......................... 3-13
4. Capacity Window Display ................................... 3-14
5. Map Window Display ......................................... 3-19
6. Mission Window Gantt Table Column Editor Display ........ 3-22
7. Allocation Preferences Display ............................. 3-23
8. Resource Inspector Display ................................. 3-24

List of Tables

1. Predefined Mission Window Gantt Sheets .................. 3-5
2. Mission Window Gantt Table Label Fields ................ 3-6
1 Document Overview

This document serves as a reference for the Barrel Allocator system, which is a component system of CAMPS (Consolidated Air Mobile Planning System). It is organized into the following sections:

1. describes the overall layout of the document
2. describes the primary capabilities provided by the Barrel Allocator system
3. describes the various Barrel Allocator system displays and documents all toolbar/menu options

This document is intended mainly to serve the needs of the typical user responsible for interacting directly with the Barrel Allocator system to solve airlift planning and scheduling problems.
This page intentionally left blank.
2 Barrel Allocator Capabilities

The Barrel Allocator provides a range of automatic and interactive airlift mission planning and scheduling capabilities.

2.1 Generation of Airlift Mission Schedules

In basic operation, the Barrel Allocator accepts a set of planned airlift missions as input, and establishes time windows and wing assignments for each. An input airlift mission (minimally) specifies:

- a cargo onload and offload location (expressed as ICAO s)
- an itinerary, or set of mission legs for transit from onload to offload location (and optionally including positioning and/or de-positioning legs)
- an “available to load time” (ALD) at the onload site and “earliest/latest arrival time” (EAD/LAD) at the offload site
- a preferred airframe (MDS) type

The scheduler produces:

1. an assignment of (notional) aircraft from specific wings to each mission (creating and inserting (de-)positioning flights as necessary)
2. an assignment of flight times to each mission leg

Currently, the following constraints are taken into account and enforced in constructing a schedule for all current missions:

- Wing capacity constraints
  Assignment of missions to wings does not exceed the number of aircraft available at each wing, taking into account aircraft that have been “fenced” for local wing use and percentages expected to be in maintenance.

- Mission time requirements
  Missions must be scheduled within timewindows designated by ALD, EAD and LAD constraints.

- Aircraft onload, offload, and minimum time-on-ground constraints
  It is possible to specify a range of different flight preparation activities and time constraints. Each of these constraints is specified as a function of MDS type.

- Flight duration constraints
  Flight durations are currently computed using great circle route.
Aircraft range constraints
These constraints are enforced when determining specific wing assignments (and hence when creating (de-)positioning flights.

Crew duty-day constraints
Crew rest is inserted at appropriate intermediate points of the mission to enforce crew duty-day constraints.

The typical mode of operation in the Barrel environment is one of integrating sets of newly planned missions into an existing current global schedule. In this mode, the scheduler will attempt to assign aircraft and schedule new missions without disrupting the current set of assignments. Any mission that cannot be integrated into the schedule in this way (which implies that there is not enough lift capacity to accomplish the mission without changing existing resource assignments) is flagged as unassignable (requiring subsequent user attention - see Section 2.4). Alternatively, the scheduler can be directed to integrate new missions into the current schedule in “priority order,” in which case the allocator may reassign or preempt lower priority missions if necessary to get newly received missions into the schedule. This range of scheduling modes provides a continuum of scheduling actions that are progressively more disruptive in the changes that can be made to the current schedule.

2.2 Generation and Assignment of Tanker Missions
In addition to generating wing/aircraft assignments and mission schedules, the Barrel Allocator also provides capabilities for generating and assigning tanker missions to airlift missions that require aerial refueling support. A set of refueling events is accepted as input, and tanker assignments can be generated either interactively or automatically. In automatic mode, the scheduler first attempts to link tanker missions that are already included in the schedule (e.g., training missions). Tanker wing assignments are determined and tanker missions are created for any remaining unsupported airlift missions.

In interactive mode, a map-based display (similar to the display in Figure 5, page 3-19) is used to indicate candidate refueling tracks that are already covered by tanker missions in the temporal interval required by a given airlift mission. The user can select one of these highlighted refueling tracks (potentially changing the originally planned refueling location) or select the current track (which will result in creation of a new tanker mission if one is not already in the schedule). In the case of the selection of a preexisting tanker mission, the system will also present opportunities to support multiple aerial refueling events with the same tanker mission (provided that fuel requirements and tanker fuel capacity constraints are satisfied).

2.3 Visualization and Analysis of Assignments
The automated, semi-automated and interactive scheduling capabilities described above are embedded in a Java-based graphical user interface that provides powerful capabilities for visualizing and analyzing
schedules. Three basic perspectives are defined for viewing the current schedule, and are discussed in the following subsections.

2.3.1 Mission Window

A mission-oriented display is provided by the Mission Window (shown in Figure 2, page 3-4). The Mission Window maintains a collection of sheets that group specific sets of missions (e.g., all assigned missions, all unassigned missions, all unassignable missions, all unrefueled missions). A filtering mechanism is also provided for selectively isolating more arbitrary sets of missions on a separate sheet. The display in each Mission Window sheet is organized as a configurable "Gantt table," with each top-level row containing information about a particular airlift or tanker mission. Columns on the left-hand side of the table indicate various properties of the mission (e.g., its POE, POD, name, mission-type, priority). The set of displayed columns can be modified dynamically according to user needs and preferences. The set of displayed missions can be sorted by clicking on any of the column headings (e.g., by descending priority, by mission type, by mission name). On the right-hand side of the table is a graphical representation of each mission's current schedule. Referring to a single top-level row in Figure 2 (e.g., corresponding to mission AJB08070E363), the blue (in this document, light grey) rectangle represents the required time interval (ALD to LAD) and the black I-beam represents the scheduled interval. A solid grey interval with a spanning I-beam designates that a mission does not yet have an assigned wing/aircraft (i.e., it is not yet scheduled). (There are no unscheduled missions shown in Figure 2.) The red (dark grey) triangles that appear on the outside edges of some I-beams represent (de-)positioning legs required by the schedule. To view further information about a given mission (as in the case of mission AJB07R300363 in Figure 2) the user can drill down (via the triangles at the left-hand side of each top-level row) to see the scheduled times of individual mission legs and crew rest periods (colored in tan (grey)).

2.3.2 Capacity Window

A second, resource-oriented view of the schedule is provided by the Capacity Window (shown in Figure 4, page 3-14). This display shows committed aircraft usage levels at an aggregate level for each wing, designating (1) the amount of fenced aircraft capacity retained locally for the wing's use (shown descending from the top of each row in green (darker grey)), and (2) the amount of aircraft capacity currently allocated by AMC to support missions (shown ascending from the bottom of each row in blue (lighter grey)). The black line shown in the capacity profile for each wing designates the current fence line (100% capacity level) and gives a quick graphical basis for recognizing those intervals where wing aircraft capacity has been over-allocated (see discussion of option analysis in Section 2.4). The red (grey) line in the profile designates the current 120% capacity level over the time intervals for each wing. By "boxing" a particular interval, the user can get a precise accounting of the types and numbers of missions currently being supported over that interval in a special commitment matrix display (not shown). Drilling down on the Capacity Window display (not shown in Figure 4) would indicate the current schedules for individual (notional) aircraft. Similar resource displays are available for viewing
current availability at various airports (as defined by MOG constraints). It is also possible to use the boxing selection capability to reduce the capacity of a particular resource over a particular interval (e.g., specify that a particular aircraft is unavailable for some period).

2.3.3 Map Window

A third, map-based display is provided through use of BBN’s OpenMap tool (shown in Figure 5, page 3-19). This display provides the capability to geographically visualize the itinerary of a given set of missions. It also provides the basic interface for interactively specifying airlift mission merging and tanker generation actions. These three visual perspectives are highly integrated and managed in a coordinated fashion. Selections in the mission window can be used to create specific resource or map-based displays, and changes made to the schedule from any display are immediately reflected in all displays.

2.4 Interactive Relaxation of Constraints and Revision of Schedules

As mentioned earlier during discussion of airlift mission schedule generation, the scheduler, in default mode, will classify as unassignable, any mission that cannot be integrated into the current schedule without some change to previous assignments or violation of constraints. In such cases, it is not possible to satisfy mission time constraints with existing available lift capacity. To support resolution of such situations, the Barrel Allocator gives the user the ability to analyze and compare various constraint relaxation options. Specifically, for any given unassignable mission (or set of unassignable missions), the user can evaluate the impact of:

- Allowing bumping of lower priority missions
  In this case the mission is rescheduled, considering possibilities to preempt lower priority missions already in the schedule. Any preempted missions are then rescheduled in succession and they may, in turn, preempt missions of lower priority still. At quiescence, any lower priority missions that cannot be fit back into the schedule are placed on the unassignable list. (Note that locked missions—regardless of priority—cannot be preempted.)

- Delaying the mission
  The user may consider the option of delaying the current mission until necessary resources are available.

- Over-allocating a wing
  The user may choose to over-allocate a given wing. (This happens with a fair amount of frequency in the case of barrel scheduling; it typically reflects extra knowledge that the barrel master may have about wing assets or agreement on the part of the wing to use fenced aircraft.)

- Delaying the mission with over-allocation
  The user may consider the option of over-allocating a given wing and delaying the current mission to obtain a possibly lower degree of over-allocation on a resource.
- Delaying with Bumping
  Similarly, the user may consider the option of bumping lower priority missions and delaying the current mission to obtain a possibly better quality bumping result (i.e., one that bumps fewer missions and/or leaves fewer unassignable lower priority missions).

- Using an alternate MDS
  It is occasionally possible to accommodate a mission if an alternative airframe can be utilized.

Any of these options can be invoked by the user in “what-if” mode. A general “undo” capability allows the retraction of any sequence of scheduling actions that have been issued by the user, and thus provides a basis for exploring alternatives. Alternatively, the user can ask the system to evaluate a group of relaxation options and then compare them within a special Mission Window display sheet (see discussion of Compare-Options mechanism in Section 3.2.1, page 3-12).

2.5 Interactive Mission Merging

A final interactive capability provided to the user to support more efficient usage of available aircraft is mission merging. Whereas missions are, by default, planned as round trips from a particular home base, mission merging attempts to exploit non-cargo-carrying positioning/de-positioning flights to support missions (such as retro-grade missions) that are flowing cargo in opposite directions. Using the map-based interface described above, a mission (perhaps currently unassignable) for which merge candidates are sought is displayed, and a query is formulated by specifying three parameters:

- Maximum layover time - the maximum time delay that can be tolerated between the offload (end) of the first mission and the onload (beginning) of the second mission
- Maximum distance - the maximum distance that can be tolerated between the locations of the first offload and the second onload
- Percentage decrease in overall flying time - by reducing two missions into one (as opposed to flying both original round trips)

2.6 Modification of Allocation Parameters

The Barrel Allocator allows the user a fine level of control of the resource allocation process through a set of parameters that dictate the behavior of the scheduler. Using the Allocation Preferences menu (shown in Figure 7, page 3-23), the user can adjust the following allocation parameters at any time:

- Resource Sets - the set of resources (of a particular MDS type) on which to search for available time to satisfy a mission
  The user can select either (1) all wings, (2) any one of a list of defined resource sets (this list is predefined to include east and west coast resource sets), or (3) the planned wing only.
  The default is to use all wings.
- **Maximum Delay** - the maximum allowable amount of delay (specified in hours)
  The default is to allow unlimited delay.

- **Maximum Over-allocation** - the maximum allowable amount of over-allocation (specified as a whole percentage)
  The default is to allow unlimited over-allocation.

- **Exclusion of local missions when bumping** - a boolean flag indicating whether local missions can be preempted during bumping
  The default is to not exclude local missions from bumping (i.e., to permit local missions to be bumped).

- **Relating to mission merging:**
  - **Maximum Layover**
    The default is to allow unlimited layover between merged missions
  - **Maximum Travel Distance Between Missions**
    The default is to allow unlimited travel distance between merged missions
  - **Minimum Travel-Time Reduction**
    The default is to allow unlimited travel-time reduction from mission merging.
3 Barrel Allocator Displays and Menu Commands

3.1 AMC-Menu Display

The AMC-Menu window shown in Figure 1 acts as the top-level Barrel Allocator control panel, from which assorted high-level allocation actions can be taken by the user.

![AMC-Menu Display](image)

**Figure 1: AMC-Menu Display**

The menu options provided by the AMC-Menu window are organized into the following groups (and described below):

- **Display commands:** for specifying display preferences, creating and manipulating windows, and exiting from the system
- **Preference commands:** for tailoring the behavior of the system
- **Database commands:** for loading mission data into the system
- **Allocation commands:** for controlling the resource allocation process
Menu Options

Display Commands:
Set Display Preferences

- **Edit > Preferences**
  The following menu suboptions allow the user to specify various display preferences:
  - **Colors** pops up a menu for changing the default colors of various types of displayed objects
  - **Look & Feel** presents a menu of window appearance theme options: [Metal (the default), CDE/Motif, Windows]

Iconify/De-iconify Windows

- **File > Iconify Windows**
  Reduces all open Barrel Allocator windows to icons
- **File > Deiconify Windows**
  Opens all currently iconified Barrel Allocator windows

View Resources

- **View > Resources**
  Pops up the Resource Inspector window (see Section 3.5.3, page 3-24), which supports the process of selecting a collection of resources for display in the Capacity Window (see Section 3.3, page 3-14)

View Missions

- **View > Missions**
  Pops up the Mission Window (see Section 3.2, page 3-4)

Exit AMC

- **File > Exit AMC**
  Closes all Barrel Allocator windows and exits

Preference Commands:

Set Debugging Options

- **Edit > Preferences**
  The following menu suboption allows the user to specify various debugging preferences:
  - **Debug** pops up a menu for selecting the level of debugging support to be provided by the system (e.g., whether or not a log file is to be maintained)
The following menu suboption allows the user to view the current settings of various system variables:

- Properties pops up a display showing the values of a range of system variables

Database Commands:

Load Missions

- File > Load Missions
  Loads into the Barrel Allocator all missions currently residing in the CDB
- File > Load New/Changed Missions from CDB
  Loads into the Barrel Allocator all new or modified missions currently residing in the CDB

Allocation Commands:

Set Current Time

- Edit > Set Current Time
  Allows the user to specify the current time within the Barrel Allocator

Assign Airlift

- Allocate > Assign Airlift
  Invokes the Barrel Allocator resource allocation process on all currently valid and unassigned missions
3.2 Mission Window Display

The Mission Window display, as introduced in Section 2.3.1, is presented in Figure 2.

![Mission Window Display](image)

**Figure 2: Mission Window Display**

Table 1 describes the set of Gantt table sheets predefined for the Mission Window, and Table 2 describes the set of all possible Gantt table column labels. The set of labels displayed in the Mission Window can be specified using the Gantt Table Column Editor (described in Section 3.5.1, page 3-22), which is brought up by clicking on the grey rectangle in the upper-left corner of the All sheet.
Table 1: Predefined Mission Window Gantt Sheets

<table>
<thead>
<tr>
<th>Sheet</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>All missions currently loaded into the system</td>
</tr>
<tr>
<td>Combined</td>
<td>Missions that have been merged with other missions</td>
</tr>
<tr>
<td>Invalid</td>
<td>Missions rejected by either the system (for violating modeling constraints) or the user (via the Allocate &gt; Reject menu option, page 3-9)</td>
</tr>
<tr>
<td>Assigned</td>
<td>Missions for which aircraft have been allocated</td>
</tr>
<tr>
<td>Unrefueled</td>
<td>Missions requiring refueling solutions</td>
</tr>
<tr>
<td>Unassignable</td>
<td>Missions for which feasible allocations have been sought but not found</td>
</tr>
<tr>
<td>Unassigned</td>
<td>Missions for which aircraft have not been allocated</td>
</tr>
<tr>
<td>Comparison</td>
<td>This sheet displays the results of evaluating the effects of selected constraint relaxations for an unassigned mission (see discussion of the Compare-Options mechanism in Section 3.2.1, page 3-12 for discussion of the special features of this sheet)</td>
</tr>
</tbody>
</table>

The toolbar and menu options provided by the Mission Window are organized into the following groups (and described below):

- Display commands: for modifying, navigating, and manipulating the Gantt table display
- Database commands: for managing changed mission data
- Mission commands: for manipulating and displaying mission objects
- Allocation commands: for controlling the resource allocation process
- Resource commands: for displaying resource objects
Table 2: Mission Window Gantt Table Label Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mission</td>
<td>The name of the mission</td>
</tr>
<tr>
<td>Priority</td>
<td>The priority of the mission (e.g., [1A1 .. 4B4])</td>
</tr>
<tr>
<td>Type</td>
<td>The type of the mission (e.g., [CHANNEL, REFUEL, DEPLOY, LOCAL, JAA TT, ...])</td>
</tr>
<tr>
<td>POE</td>
<td>The point-of-embarkation (origin) for the mission (i.e., an ICAO)</td>
</tr>
<tr>
<td>POD</td>
<td>The point-of-debarkation (destination) for the mission (i.e., an ICAO)</td>
</tr>
<tr>
<td>Status Flag</td>
<td>The status flag for a mission</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the mission</td>
</tr>
<tr>
<td>Wing</td>
<td>The wing to which the mission is assigned</td>
</tr>
<tr>
<td>Lock</td>
<td>A flag indicating whether a mission assignment is locked</td>
</tr>
<tr>
<td>Operator ID</td>
<td>The wing responsible for a mission</td>
</tr>
<tr>
<td>MDS type</td>
<td>The intended MDS (aircraft) type for the mission</td>
</tr>
</tbody>
</table>

Toolbar/Menu Options

Display Commands:

Modify Gantt Table Display

- **Toolbar Option**
  - **Show Crosshair**
    - Changes the cursor into a crosshair
  - **Show Vertical Lines**
    - Toggles between showing and hiding the vertical lines in the right-hand side of the Gantt table display
  - **Zoom In**
    - Zooms in on the Gantt table display by a factor of 200% (anchoring on the left-hand side)

Mission Window Display
3-6
- **Toolbar Option** Zoom Out
  Zooms out on the Gantt table display by a factor of 50% (anchoring on the left-hand side)

- **Toolbar Option** Time Granularity
  Allows the user to modify the time granularity of the Gantt table display using a pull-down menu of predefined time periods
  (Note: this option is located in the lower right-hand corner of the display; instead of a Time Granularity toolbar heading, it displays the currently selected time granularity (the default time granularity is Days).)

Choose Object-Selection Mode
- **Toolbar Option** Arrow
  Changes the cursor into the default arrow pointer (i.e., for selecting missions in the Gantt table display)

- **Toolbar Option** Rectangle
  Changes the behavior of the cursor to support click-and-drag rectangle creation (i.e., for selecting time intervals in the Gantt table display)

- **Toolbar Option** Select All
  Selects all missions displayed in the current Gantt table sheet (equivalent to the Edit > Select All menu option)

- **Toolbar Option** Deselect All
  Deselects all selected missions in the current Gantt table sheet (equivalent to the Edit > Deselect All menu option)

Show/Hide Object Information
- **Toolbar Option** Show Annotations
  Toggles between showing and hiding the textual mission annotations in the Gantt table display

Manipulate Gantt Table Sheets
- **Sheets > Open Sheet in New Window**
  Creates a new Mission Window containing only the current sheet

- **Sheets > Split Window**
  Splits a single-pane Gantt table sheet into two half-pane sheets
- [Sheets] Unsplit Window
  Restores a split Gantt table sheet into a single sheet (by removing the lower one)

- [Sheets] Refresh Sheets
  Refreshes the current Gantt table sheet

- [Sheets] Print Active Sheet
  Prints a copy of the current Gantt table sheet

- [Sheets] Rename Active Sheet
  Allows the user to assign a name to the current Gantt table sheet

- [Sheets] Delete Sheet
  Deletes the current Gantt table sheet

**Close Mission Window**

- [Edit] Close Window
  Closes the Mission Window

**Database Commands:**

**Highlight Changed Missions**

- [Edit] Show All Changed Missions
  Highlights all missions that have changed since being loaded from the CDB

- [Edit] Show Time Changed Missions
  Highlights all missions whose start and end times have changed since being loaded from the CDB

- [Edit] Show Wing Changed Missions
  Highlights all missions whose wing assignment has changed since being loaded from the CDB

**Manage Mission Changes**

- [Edit] Commit Changed Missions
  Commits all changed missions back to the CDB

- [Edit] Clear Changed Missions
  Restores all uncommitted changed missions back to their original state
Mission Commands:

Modify Mission Display
- Edit ▶ Filter Missions
  Allows the user to specify a set of mission filters (based on the Gantt table label fields described in Table 2, page 3-6) for defining a collection of missions to be displayed in a special sheet in the Mission Window.

Edit Mission Attributes
- Edit ▶ Edit Missions
  Pops up an editor window that allows the user to modify a selected mission.
- Edit ▶ Set Start and End Time
  Prompts the user to specify a start and end time for a selected mission.

Invalidate Mission
- Allocate ▶ Reject
  Allows the user to invalidate a selected mission.

View Mission Detail
- Edit ▶ Open Mission Detail
  Queries the CDB for additional mission details.
- Edit ▶ Show Links
  Toggles between showing and hiding the links between missions (e.g., as in the case of refueling assignments).
- Map ▶ Show Missions
  Pops up the Map Window (see Section 3.4, page 3-18) to display a selected mission.

Allocation Commands:

Assign/Cancel Aircraft
- Allocate ▶ Assign Airlift
  Invokes the Barrel Allocator resource allocation process on all currently valid and unassigned missions.
- Allocate ▶ Cancel Assignment
  Cancels the aircraft assignment for a selected mission.
Lock/Unlock Assignments

- Allocate > Lock
  
  Locks the aircraft assignment for a selected mission
  
  Locked assignments cannot be canceled or preempted (i.e., during bumping)
  
  (Note: locking can also be achieved by setting the flag in the Gantt table Lock column, if it is displayed)

- Allocate > Unlock
  
  Unlocks the aircraft assignment for a selected mission
  
  (Note: unlocking can also be achieved by unsetting the flag in the Gantt table Lock column, if it is displayed)

Generate Assignment Transcript

- Allocate > Allocation Transcript
  
  Generates a textual transcript of an allocation for a selected mission

Compare Options

- Options > Compare Options
  
  Applies the Compare-Options mechanism to a selected mission according to the currently selected constraint relaxation options and pops up a Gantt table Comparison sheet in the Mission Window to display the results (see Section 3.2.1, page 3-12)

Edit Constraint Relaxation Options and Allocation Parameters

- Options > Allocation Preferences
  
  Allows the user to specify both the constraint relaxation options to be evaluated by the Compare-Options mechanism and the allocation preferences for all resource allocation processes

Assign Aircraft - Allowing Bumping

- Options > Allow Bumping
  
  Attempts to assign an aircraft to a selected mission using resource capacity freed up by unlocked lower-priority missions

Assign Aircraft - Allowing Delay

- Options > Late on Closest Wing
  
  Attempts to assign an aircraft to a selected mission by relaxing its due date (i.e., permitting tardiness) on the closest wing

- Options > Minimize Tardiness
  
  Attempts to assign an aircraft to a selected mission by relaxing its due date and minimizing tardiness across the set of usable resources

Assign Aircraft - Allowing Over-allocation

- Options > Over-allocate Closest Wing
  
  Attempts to assign an aircraft to a selected mission by relaxing resource capacity constraints (i.e., bumping maintenance operations) on the closest wing
• **Options ▶ Least Committed Wing**
  Attempts to assign an aircraft to a selected mission by relaxing resource capacity constraints across the set of usable resources and minimizing the amount of over-allocation.

**Assign Aircraft**
- **Options ▶ C017**
  Attempts to assign a C017 MDS type to a selected mission.

- **Options ▶ C005**
  Attempts to assign a C005 MDS type to a selected mission.

- **Options ▶ C141**
  Attempts to assign a C141 MDS type to a selected mission.

- **Options ▶ KC010**
  Attempts to assign a KC010 MDS type to a selected mission.

- **Options ▶ KC135**
  Attempts to assign a KC135 MDS type to a selected mission.

- **Options ▶ C130**
  Attempts to assign a C130 MDS type to a selected mission.

**Undo/Redo Actions**
- **Toolbar Option**
  **Undo Last Action**
  Undoes the most-recent allocation or cancelation action (equivalent to the Allocate ▶ Undo menu option).

- **Toolbar Option**
  **Redo Last Action**
  Redoes the most-recently undone allocation or cancelation action (equivalent to the Allocate ▶ Redo menu option).

**Resource Commands:**
- **Edit ▶ Create Resource Window**
  Pops up the Capacity Window (see Section 3.3, page 3-14) to display the resources associated with a group of selected missions.
3.2.1 Comparison Sheet

The Comparison sheet displays the results obtained from invoking the Compare-Options mechanism on a selected mission in the Mission Window via the Options > Compare Options menu item (see page 3-10). Each of the user-selected constraint relaxation options (see Section 3.5.2, page 3-23) is applied to the selected mission, and the results are presented in a special Mission Window Comparison sheet, as shown in Figure 3. In the event that a mission can be feasibly allocated, the Compare-Options mechanism will identify that solution (or solutions) in the results and remove any such feasible resources from the set of resources considered for the remaining selected allocation options.

The results presented in the Comparison sheet are grouped according to relaxed constraint allocation option and ordered by quality. Textual annotations provide information about the quality of each relaxed allocation, including start and end times, and if applicable, amounts of delay, over-allocation and bumping, and merging statistics. In the case where multiple allocation solutions are found for a particular option, the best solution is presented in bold face. These bold-faced row entries can be expanded (using the triangle icon on the left side of the row) to see additional solutions, and in the case of Bumping, to view the full extent of the solution.

To implement a particular allocation solution listed in the Comparison sheet, the user can simply double-click on its row. To exit from the sheet without committing to any solution, the user can double-click on the red (grey) CANCEL row at the top of the sheet. Note that any decisions made in this sheet can be undone and redone using the Mission Window’s Undo and Redo toolbar/menu options (see page 3-11).
Figure 3: Mission Window Comparison Sheet
3.3 Capacity Window Display

The Capacity Window display, as introduced in Section 2.3.2, is presented in Figure 4.

![Capacity Window Display](image)

**Figure 4: Capacity Window Display**

The toolbar and menu options provided by the Capacity Window are organized into the following groups (and described below):

- Display commands: for modifying, navigating, and manipulating the resource capacity display
- Allocation commands: for triggering the resource allocation process
- Mission commands: for displaying mission objects
Toolbar/Menu Options

Display Commands:

Modify Resource Capacity Display
- **Toolbar Option** Show Crosshair
  Changes the cursor into a crosshair

- **Toolbar Option** Show Vertical Lines
  Toggles between showing and hiding the vertical lines in the resource capacity display

- **Toolbar Option** Zoom In
  Zooms in on the resource capacity display by a factor of 200% (anchoring on the left-hand side)

- **Toolbar Option** Zoom Out
  Zooms out on the resource capacity display by a factor of 50% (anchoring on the left-hand side)

- **Toolbar Option** Time Granularity
  Allows the user to modify the time granularity of the resource capacity display using a pull-down menu of predefined time periods
  (Note: this option is located in the lower right-hand corner of the display; instead of a Time Granularity toolbar heading, it displays the currently selected time granularity (the default time granularity is Days).)

Choose Object-Selection Mode
- **Toolbar Option** Arrow
  Changes the cursor into the default arrow pointer (i.e., for selecting time intervals in the resource capacity display)

- **Toolbar Option** Rectangle
  Changes the behavior of the cursor to support click-and-drag rectangle creation (i.e., for selecting time intervals in the resource capacity display)
Select All
Selects all time intervals displayed in the resource capacity display (equivalent to the Resources > Select All menu option)

Deselect All
Deselects all selected time intervals in the resource capacity display (equivalent to the Resources > Deselect All menu option)

Misc > Grid
Allows the user to select the granularity of the grid used to control the movement of the Rectangle cursor when selecting a time interval. In addition to the No Grid option, which permits maximum flexibility, a range of predefined granularity values are provided: [Years, Months, Days, Hours, Minutes, Seconds, Simple, Julian, Weekly, Six Hours]

Show Annotations
Toggles between showing and hiding the textual annotations in the resource capacity display

Show Locals/Jaatts
Toggles between showing and hiding the amount of resource capacity allocated to LOCAL and JAATT missions

Show 100%
Toggles between showing and hiding the 100% capacity line (in black) for each resource entry row in the capacity display

Show 120%
Toggles between showing and hiding the 120% capacity line (in red) for each resource entry row in the capacity display

Show Interval Usage
Pops up a Commitment Matrix display window that summarizes resource usage for a selected time interval

Show Daily Usage
Pops up a Commitment Matrix display window that summarizes resource usage for a single day (i.e., the one encompassing the present cursor location)
Print Capacity Window

- **Resources ▷ Print Window**
  Prints a copy of the Capacity Window

Close Capacity Window

- **Resources ▷ Close Window**
  Closes the Capacity Window

---

**Allocation Commands:**

**Assign Aircraft**

- **Schedule ▷ Schedule**
  Invokes the Barrel Allocator resource allocation process on all currently valid and unassigned missions

- **Schedule ▷ Automatic Merging**
  Attempts to merge missions within the selected time interval

---

**Mission Commands:**

**View Mission Detail**

- **Edit ▷ Create Order Window**
  Pops up the Mission Window (see Section 3.2, page 3-4) to display a group of missions associated with a selected time interval. The selected missions are displayed on a special sheet in the Mission Window.
3.4 Map Window Display

The Map Window display, as introduced in Section 2.3.3, is presented in Figure 5. The toolbar and menu options provided by the Map Window are organized into the following groups (and described below):

- **Display commands**: for modifying, navigating, and manipulating the map display
- **Navigation commands**: for navigating within the map display
- **Allocation commands**: for triggering the resource allocation process

**Toolbar/Menu Options**

**Display Commands:**

**Modify Display**

- **View > Mouse Highlighting**
  Toggles between a mouse-tracking mode where assorted map objects are highlighted when passed over by the cursor and the default mode in which nothing is highlighted

- **Projections**
  Allows the user to select from among three predefined map projections: [Mercator, Orthographic, CADRG] (the default is Mercator)

- **Options > Show Missions**
  Toggles between showing and hiding all missions (cargo-carrying legs only) in the map display

- **Options > Show Legs**
  Toggles between showing and hiding all legs (i.e., positioning/de-positioning) in the map display

- **Options > Show Both**
  Toggles between showing and hiding all missions, including their positioning/de-positioning legs, in the map display

- **Options > Show Location**
  Toggles between showing and hiding all locations in the map display

- **Options > Show Labels**
  Toggles between showing and hiding all labels in the map display
Figure 5: Map Window Display
- **Options > Show Refueling Tracks**
  Shows refueling tracks for a mission in the map display

- **Options > Show All Refueling Tracks**
  Shows all refueling tracks in the map display

- **Options > Hide Refueling Tracks**
  Hides all refueling tracks in the map display

### Set Mission Filters

- **Filter**
  Allows the user to select from among a set of predefined filters to dictate the set of missions shown in the map display

### Refresh Window

- **Map > Refresh**
  Refreshes the map display

### Close Map Window

- **Map > Close**
  Closes the Map Window

### Navigation Commands:

#### Change View

- **Toolbar Option**
  Compass Rose
  Allows the user to rotate the map in eight directions (i.e., N, SE, E, SE, S, SW, W, NW) and orient it (by clicking on the center icon)

- **Regions**
  Allows the user to center the map on any of a list of predefined geographical regions

- **Map > Select New Center**
  Allows the user to select a new center for the map by clicking anywhere on the map display

#### Zoom In/Out

- **Map > Zoom (select)**
  Allows the user to zoom in on a selected region by means of a standard click-and-drag rectangle-creation process

- **Toolbar Option**
  Zoom In
  Zooms in on the map display, retaining the current center location (equivalent to the Map > Zoom In menu option)
The Barrel Allocator

User Reference: Version 1.0

- **Toolbar Option**
  - **Zoom Out**
  Zoons out on the map display, retaining the current center location (equivalent to the Map > Zoom Out menu option)

- **Toolbar Option**
  - **Scale**
  Allows the user to specify a scale for the map display
  (Note: this option is located along the top of the display; instead of a Scale toolbar heading, it displays the current map scale.)

Allocation Commands:

- **Calculate**
  - **Merge Candidates**

- **Toolbar Option**
  - **Merge Candidates**
  Attempts to find all feasible merge candidates for the selected mission
3.5 Supporting Displays

3.5.1 Mission Window Gantt Table Column Editor

The Mission Window Gantt Table Column Editor display, as introduced in Section 3.2, is presented in Figure 6. It permits the user to specify the set of labels displayed in the Mission Window, and is brought up by clicking on the grey rectangle in the upper-left corner of the All sheet.

![Figure 6: Mission Window Gantt Table Column Editor Display](image)

Clicking on a column label will select that label and de-select all others. Shift-clicking will select every label between the current label and the closest preceding label; control-clicking will select a label without changing the existing selections. The vertical lines for the left-hand side of the display and the horizontal lines for the entire display can be shown/hidden using the checkboxes in the Misc. (right-hand) side of this menu.
3.5.2 Allocation Preferences Menu

Figure 7 shows the Allocation Preferences menu display, which allows the user to specify both the allocation preferences for the Compare-Options mechanism and parameter values for all resource allocation processes.

The upper half of the Allocation Preferences menu allows the user to specify the set of constraints to be relaxed by the Compare-Options mechanism by means of a set of checkboxes and a single pull-down menu (for the Alternate MDS Types option). The set of relaxable allocation constraints supported by the Barrel Allocator is described in Section 2.4 (page 2-4). All changes made in this menu and confirmed by selecting the OK button will remain in effect until a future change.

The lower half of the Allocation Preferences menu allows the user to specify the bounds for the relaxation of constraints during the resource allocation process. The set of resource allocation parameters supported by the Barrel Allocator is described in Section 2.6 (page 2-5). Again, all changes made in this menu and confirmed by selecting the OK button will remain in effect until a future change—and will apply to all subsequent resource allocation activities (i.e., for Compare-Options and otherwise).
3.5.3 Resource Inspector

The Resource Inspector window, as shown in Figure 8, displays the currently defined resource hierarchy, from which the user can select a group of resources for which to view capacity information that will be displayed in a corresponding Capacity Window (see Section 3.3, page 3-14).

![Resource Inspector Display](image)

Figure 8: Resource Inspector Display